1

I have tried to export a list inside my SharePoint 2013 , but I got the following error:

Sorry, something went wrong The backup/restore job failed because there is already another job scheduled. Delete the timer job from the Timer Job Definitions page, and then restart the backup/restore job.

After googling this, I went to my "job definition", but I can not find "Backup / Restore" job to delete it. Can anyone advice?

1

you might need to reset the timer service! I had a similar issue, I found this script online and it does the job perfectly (cant remember where i got it from tho, i think it was for 2010 but iv changed it for 2013)!

2013 powershell script:

[array]$servers= Get-SPServer | ? {$_.Role -eq "Application"}            
$farm = Get-SPFarm            
foreach ($server in $servers)            
{            
    Write-Host "Restarting Timer Job on $server"                                      
    $Service = Get-WmiObject -Computer $server.name Win32_Service -Filter "Name='SPTimerV5'"                        
    if ($Service -ne $null)                         
    {                             
        $Service.InvokeMethod('StopService',$null)            
        Start-Sleep -s 7            
        $service.InvokeMethod('StartService',$null)                             
        Start-Sleep -s 7            
        Write-Host "Timer Job successfully restarted on $server"                        
    }             
    else            
    {            
        write-host -ForegroundColor Yellow "Could not find Sharepoint 2013 Timer Service on $server"            
    }            
}

just copy past code into notepad++ and save as ps1, open up powershell and drag drop the ps1 file into powershell and hit enter!

EDIT

ok we need to get the name of the job that is failing:

can you run this script and see what job is failing:

$f = get-spfarm
$ts = $f.TimerService
#Display all jobs that haven't succeeded (I.e. Paused)
$ts.JobHistoryEntries | ?{$_.Status -ne "Succeeded"} | Ft JobDefinitionTitle,Status
#Display only failed jobs
$ts.JobHistoryEntries | ?{$_.Status -eq "Failed"} | Ft JobDefinitionTitle,Status
#Display more information
$ts.JobHistoryEntries | ?{$_.Status -eq "Failed"} | fl

http://social.technet.microsoft.com/Forums/sharepoint/en-US/8a01869c-9065-4b55-aca4-0eb61ca5cd97/failed-timer-jobs-via-powershell?forum=sharepointgeneralprevious

EDIT

the error you got indicated the user your using doesn't have the correct privileges! hence why iv asked you todo the above to see where its going wrong!

Have you tried using powershell to export the list?

1.Verify that you have the following memberships:

◦ securityadmin fixed server role on the SQL Server instance.

◦ db_owner fixed database role on all databases that are to be updated.

◦Administrators group on the server on which you are running the Windows PowerShell cmdlets.

An administrator can use the Add-SPShellAdmin cmdlet to grant permissions to use SharePoint 2013 cmdlets.

http://technet.microsoft.com/en-us/library/ff607596.aspx

2.Start the SharePoint 2013 Management Shell.

◦For Windows Server 2008 R2:

◾On the Start menu, click All Programs, click Microsoft SharePoint 2013 Products, and then click SharePoint 2013 Management Shell.

◦For Windows Server 2012:

◾On the Start screen, click SharePoint 2013 Management Shell.

If SharePoint 2013 Management Shell is not on the Start screen:

◾Right-click Computer, click All apps, and then click SharePoint 2013 Management Shell.

3.At the Windows PowerShell command prompt, type the following command:

Export-SPWeb -Identity <SiteURL> -Path <Path and File Name> [-ItemUrl <URL of Site, List, or Library>] [-IncludeUserSecurity] [-IncludeVersions] [-NoFileCompression] [-GradualDelete] [-Verbose]

Where:

◦ is URL for the site, list, or library that you are exporting.

◦ is path and name for the site, list, or library that you are exporting.

◦ is the URL for the site, list, or library where you are exporting.

http://technet.microsoft.com/en-us/library/ee428301.aspx

http://technet.microsoft.com/en-us/library/ff607895.aspx

example

Export-SPWeb http://mysite.test.com –Path "c:\tempFolder\list export.cmp" -ItemURL "/subsite/documents" -force

first part is the site where list is located, second is the folder path where were going to store the exported list, third is the subsite location of the list and fourth is forcing this command

10
  • can not drag and file inside power shell... – john Gu Jan 14 '14 at 13:39
  • ok i typed your command inside power shell and no error were raised inside power shell. but when i tried to export the list i got the same original error ... – john Gu Jan 14 '14 at 13:41
  • is the file on your desktop? it will work if it is in desktop, also make sure that your using sharepoint managment shell and not the standard powershell! – Ali Jafer Jan 14 '14 at 13:42
  • 1
    you now need to check again at timer job definitions and see if you can see it there! – Ali Jafer Jan 14 '14 at 13:49
  • it is still not inside the job defenition . i went to CA >> monitoring >> job defenition . no job starts with Backup .. – john Gu Jan 14 '14 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.