3

I have 2 lists, one allows anonymous access but the other does not. Here are the details of what I setup and what I've checked to resolve this (they should both Illow anonymous access).

Each list has a new version of the NewForm.aspx, called us.aspx. There is no difference in the aspx pages. I checked them, and even copied the content from the working us.aspx to the other.

I've checked the permissions for each list, and both have Anonymous Users setup with Add Items, View Items, and the same number of other groups and all permissions match.

If I go to (equivalent of) /site/Lists/list1/us.aspx I can see the form, but if I go to /site/Lists/list2/us.aspx I'm redirected to my login page.

Where else in SP2010 can I find permissions for a list?

Added 7-Apr-2014 Well, now the list that was working is exhibiting the same issue, in that even though my list permissions are set to "Add Items, View Items" for Anonymous Users, such users are prompted to login before they can view the form.

  • Just to be clear... Have you confirmed that anonymous users can access the landing page of both lists? Meaning an anon user can access site/Lists/list2/ just fine? – Robert Kaucher Apr 7 '14 at 16:45
  • As it stands, anonymous users cannot access the list at all. Using your example, I tried to access my list without specifying the .aspx page, and I'm still redirected to a login page. I have this on a dev server and it works, checking permissions between the two lists (list1 on www and list1 on dev) both are the same. I'm wondering if there is another place that sets anonymous access for all lists in the site collection? – QMKevin Apr 7 '14 at 16:54
  • But anonymous users can access one of the lists on this same site, right? – Robert Kaucher Apr 7 '14 at 17:33
  • 2
    Have you enabled anonymous access on the web application itself? Without that, assigning permissions will not actually do anything. – Robert Kaucher Apr 7 '14 at 17:36
  • 1
    More background info: This is part of a public facing website, that's been running for a few years. Anonymous access is allowed throughout the site, and has been working with the lists in question until, it appears, last Thursday. I've found no evidence that anything changed, just that the direct input pages (list/NewForm.aspx) is now prompting anonymous visitors to login. Anonymous visitors used to be able to access all lists, and then one started prompting for login (hence the initial question) but now all lists are prompting. – QMKevin Apr 7 '14 at 18:48
1

First: Double check that the web application allows anonymous. The web app is where the authentication protocols for your hostname are set. This has two steps

  1. The authentication provider needs to be set to "enable anonymous access"
  2. The web application needs to have an anonymous policy set to "no policy" and you should have the zones set to "all zone"

Next: make sure that your site has the anonymous policy set to "Lists and Libraries". If you do not see the anonymous access in the ribbon, then this means that the web application is not set to allow anonymous access.

I have taken a screen shot of this from my environment Sp 2013

Lastly: make sure that nothing has changed with the anonymous account, and that it can access your SharePoint site. Just because anonymous access is enabled, doesn't mean authentication takes place. It does, but all users use the same account that IIS creates called IUSR_computername. If this account has been changed from the default to a domain account, then make sure that the password isn't expired for it.

Here is some good info that will help you rule out something being wrong with the anonymous account IIS uses. This is pretty good too.

| improve this answer | |
  • The site itself is still accessible to anonymous users, it's just these lists that's causing a problem. I don't see any user in AD starting with IUSR_ - I do see a group called IIS_IUSR, and in that group I see 'IUSR' but searching for that user shows no results. Odd, right? – QMKevin Apr 10 '14 at 14:35
  • That user is often a local user on the server and not a domain user. To see which user is actually being used you will want to go on the WFE server and see how IIS is setup. The 2nd link I provided should you locate that user. You have likely already done this, but make sure that those list don't expose any information from a different site (like a lookup column or something), and that inheritance isn't broken (if it is you may want to reset it just to help with debugging). Hopefully you get it figured out! – TigerBear Apr 10 '14 at 16:25
  • And if the anonymous authentication is working in other areas, then you can rule out something being wrong with the anonymous access account. – TigerBear Apr 10 '14 at 16:25
1

disable the ViewFormPagesLockdown and try

ViewFormPagesLockDown feature in SharePoint In General by enabling the anonymous access in SharePoint site, anonymous users will have read-only access to the site. But when we enable anonymous access to SharePoint publishing site, we can have issues with anonymous users in SharePoint site due to ViewFormPagesLockDown feature. This feature will block users to view list view pages. Users can able to access all other web pages. Generally we can face this issue whenever users wanted to comment a blog post as anonymous in SharePoint blog site located in SharePoint publishing site collection.

Source

| improve this answer | |
  • Please provide more details. – Karthik Jaganathan Apr 10 '14 at 9:34
  • Add more details, or you are at risk of getting your answer converted to a comment. Provide details regarding how to disable the ViewFormPagesLockdown – Robert Lindgren Apr 10 '14 at 9:36
  • Robert I have updated my question. You are very expert in Putting -1. – SharePointMan Apr 10 '14 at 9:44
  • Robert since I have updated my question, will u please remove your downvote? so that owner of the question can consider this answer? – SharePointMan Apr 10 '14 at 11:37
0

there are a few areas it could be going wrong!

firstly check that the lists in question have not had their permission level inheritance broken, if so why? as you said the site allows annoymous users.... unless you want different permissions for the list?

secondly:

make sure your site is not in lockdown:

To determine if a site has ViewFormPagesLockdown enabled run the following:

get-spfeature -site http://sitecollectionURL

If ViewFormPagesLockDown is listed, it's enabled.

To toggle lockdown mode to off:

$lockdown = get-spfeature viewformpageslockdown

disable-spfeature $lockdown -url http://sitecollectionURL

If anonymous is already setup, you may need to disable\re-enable anonymous on the site.

http://blogs.msdn.com/b/russmax/archive/2010/01/22/lockdown-mode-in-sharepoint-2010.aspx

| improve this answer | |
  • Finally back at my desk, so I gave this a look. ViewFormPagesLockDown was indeed listed, so I disabled it. I do recall doing this before, so not sure why it came back. The MSDN article says to disable/re-enable anonymous on the site. I assume it means the site collection, but doing that made no difference. Any further ideas? or indication if I'm in the wrong place for anonymous permissions. – QMKevin Apr 10 '14 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.