1

So today suddenly all but the very latest (added within this week) users disappeared from MySites and our People Directory.

What could of caused this to happen? How can I restore everyone's profiles?

I am using SharePoint 2010.

3
  • A couple a things to check. Start with your User Profile Service Application. Is your sync connection working correctly? Start a full profile sync. Did the AD sync account change or password on it change?
    – Mike
    Jan 9, 2014 at 21:40
  • Check with your AD team. Did they change the name of the User OU? Jan 10, 2014 at 13:16
  • Nothing with the AD changed... There was however what I would call a "blip" in the network, when stuff suddenly acted strange. It was during this time frame that i lost all those users. I ran a full sync this morning and everyone became visible again... The downside is I had to go through and Exclude multiple accounts again from Employee Directory, and all profile pictures were gone.
    – Capurnicus
    Jan 10, 2014 at 17:52

1 Answer 1

1

If you have a backup of the User profile Databases (Profile DB + Social DB) don't need the sync DB. Once you have restored and configured your UPA, and run the user sync jobs (full + incremental) a few times, query the Profile DB database:

Select * from userprofile_full (nolock) where bDeleted = 1

(Not recommended but I had to do this:

update dbo.UserProfile_Full set bDeleted=0 where bDeleted =1)

The next time the User profile sync job runs it will clear the users that do not exist anymore in AD

Refer to this article: http://rehmanfaiz.blogspot.com.au/2014/01/restoring-user-profile-service.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.