0

I have an issue with checking out documents. The option to save the document locally does not appear at all therefore presumably the document stays on the server. We want to be able to work offline with checked out docs but at present cannot.

I checked Settings -> Document Library Settings -> Versioning Settings -> ‘Require documents to be checked out before they can be edited?’ is set to 'Yes' but still not getting the option to save locally upon editing and checking out.

Help please!

(This is MOSS 2007 btw)

  • What kind of browser are you using? Also, what folder are you looking at? In 2007, it should be under c:/users/<user>/documents/my sharepoint drafts – Mike Jan 9 '14 at 16:29
  • Browser is IE. All the help documents show upon editing/checking out the document the option to tick the box to save it locally but this is not appearing. Checked the folder structure as you've supplied and no such folder exists. I've contacted our IT dept and am being told could be something to do with using office 2003? Apparently it works ok on 2007 and above. Realistically we can't upgrade everyones machines! – jcool Jan 9 '14 at 16:57
  • The "Require documents to be checked out before they can be edited" setting on the Document Library needs to be enabled. Select 'Yes' to have the prompt appear. This affects both Word 2003 and Word 2007 – Mike Jan 9 '14 at 17:04
  • Mike, as stated in original question this is set to 'Yes' yet I'm still not getting the option to save it to local when checking out. – jcool Jan 10 '14 at 8:50
2

There is an add-on of IE called “SharePoint OpenDocuments Class”, and if it’s disabled or not existing, the “use your local drafts folder” window will not pop up. So please check this add-on of IE and enable it.

If the add-on does not exist, you can install it and also here is another workaround: if you want to use the local drafts folder, just open Office Word -> click on Office button -> Word Options -> Save, under “Save checked-out files to”, select “The server drafts location on this computer” and specify a location in Server drafts location. After this configuration, the checked-out file drafts will be saved in the location specified. http://social.technet.microsoft.com/Forums/en-US/sharepointcustomization/thread/f28735f1-ded6-4c52-8738-2f6dd3daccce

  • Hi thanks for your response. I cannot find this add-on and won't be able to install it (company rules). As stated in comment above most users are operating office 2003 so this "save checked out files to" doesn't exist in options either... I tried checking "Make local copy of files stored on network or removable drives" (as this seems closest option to the one you describe) and still not working. – jcool Jan 9 '14 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.