3

I've been using SharePoint Foundation 2010 for a while with Window 7 and Office 2010 with no issues as far as creating the local drafts folder where expected and placing the checked out file in that folder.

Last week, got a new computer with Windows 8 and Office 2013 and now SharePoint 2010 does not create the local drafts folder but does show the document as checked out.

Word 2013 options are populated with the usual local directory name for the check out. I've checked everything mentioned online but no ultimate resolution for this issue. Does anyone care to share your lessons learned regarding this issue?

Also, I'm selecting to "edit" the file but still no "Visible" SharePoints local draft folder..

1
  • Also, I'm selecting to "edit" the file but still no "Visible" sharepoints local draft folder..
    – Nancy Page
    Jan 9, 2014 at 14:22

3 Answers 3

1

There is an add-on of IE called “SharePoint OpenDocuments Class”, and if it’s disabled or not existing, the “use your local drafts folder” window will not pop up. So please check this add-on of IE and enable it.

If the add-on does not exist, you can install it and also here is another workaround: if you want to use the local drafts folder, just open Office Word -> click on Office button -> Word Options -> Save, under “Save checked-out files to”, select “The server drafts location on this computer” and specify a location in Server drafts location. After this configuration, the checked-out file drafts will be saved in the location specified. http://social.technet.microsoft.com/Forums/en-US/sharepointcustomization/thread/f28735f1-ded6-4c52-8738-2f6dd3daccce

If it happens only on PDF documents, please refer to this: http://social.technet.microsoft.com/Forums/en-US/sharepointcustomization/thread/25b03f5c-7117-46cf-8471-dd12c7f1209a

1
  • Reviewed and checked all of these recommendations before posting the question. Specifically, I notice that the "Use local drafts folder" CHECKBOX does not appear in the IE dialog box which creates the folder and places the file locally. Could this be an IE10 compatibility issue with Word 2013, Windows 8, and SharePoint Foundation 2010?
    – user21871
    Jan 9, 2014 at 20:57
1

According to Microsoft, here's the answer:

In Office 2013 it is by design that the “Use my local drafts folder” functionality has been removed for Office 2013.

This step has been done in order to improve the Client/Server communication by removing some of the redundant network calls generated by this process. In order to get office files synchronized with SharePoint document libraries you could use SkyDrive Pro instead. SkyDrive Pro is getting installed with Office 2013 but is available as a standalone setup as well. But please note that SkyDrive Pro requires to have a SharePoint server 2013 installed or a O365 subscription, which brings SPO 2013.

If you want to use the “use my local drafts folder”, you should install the Office 2010 instead of Office 2013.

0

One thing I have noticed is that the "Office Upload Center" will still cache the document that you check-out. So this will still make the file available offline.

To reproduce do the following:
1. Check out the document in SharePoint
2. Open the Upload Center by double clicking the icon in the sysTray
3. Change the view from "Pending Uploads" to "All Cached Files"
4. You should notice your checked out file is listed in the files cached on your computer
5. Double click the document in the cache or use the "Recent Documents" in word to open the file while offline.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.