1

The "Assigned To" column in my SharePoint 2013 tasks list show all values as blank. However, I can use filter by user correctly. This occurs in every location I have a task Webpart (main page and tasks list). This occurred early in the development of this site but was set as a minor issue and left till now to fix (it is now one of our major issues).

enter image description here

Assigned to looks blank

enter image description here

Filter still works (values are there)

enter image description here

Interestingly if you go into edit and double click the field it shows the text. If you highlight the whole page normally, nothing is there (so it's not just shown in white or something dumb)

What I've tried so far:

  • Deleting and creating a new webpart to display the list
  • Disabling Assigned to from the view and re-enabling it
  • Changing view back to a default SharePoint one
  • Using a different computer
  • Using different account (admin/user)
  • Deleting all tasks and creating new ones
  • Changing the "Show field" option (Settings > Edit Column) to various things, the values shown on the filter are updated accordingly but still not shown on the page.
  • Dug through all the settings I could find (I’m hoping I’ve just missed one)
  • Reset the server (because why not)

I do use the value "Assigned to" in my approval workflows, which is one of the only non-standard things I can think of relating to this field but should not cause this problem.

I'm assuming this is just a setting somewhere, or a SP bug (although I can't find any similar problem on the web)

Thanks!

  • Is the field visible in Edit form. – Nadeem Yousuf Jan 9 '14 at 4:38
  • This must be browser compatible issue. Did you check this out in some other browser ? – Prasath Sivagnanam Jan 9 '14 at 5:35
  • Is the the colour set to White for this column's content? – Robban1980 Jan 9 '14 at 6:32
  • @NadeemYousuf I'm not sure what you mean by edit form (sorry still learning SP) if I click the quick edit button the fields look blank unless double clicked on which then shows the text (shown in the pic above) – Ryan Walker Jan 9 '14 at 7:30
  • @PrasathS Just tried in Firefox and Chrome (was working in IE before), no luck but good suggestion I did not think of that. – Ryan Walker Jan 9 '14 at 7:31
1

Can you try this:

  1. Click on Settings at the top and then click on Edit Page.
  2. Then Select the web part representing the list. At the top right click on Edit Web Part.
  3. Go to Miscellaneous section and select Server Render. Click OK.

Let me know if it helps. I recently faced a somewhat similar issue which I blogged here.

http://sharepointnadeem.blogspot.in/2013/12/sharepoint-2013-upgrade-sharepoint-2010.html

  • Thankyou! this works perfectly :). – Ryan Walker Jan 13 '14 at 0:43
0

I have seen this before when there are certain characters in a users display name such as an extended hyphen. Try changing the show field setting of the "Assigned To" field from Name to Account.

To do this go to the list settings page, select the "Assigned To" column and towards the bottom there is a property called "Show field" - change the value to "Account" and save the changes.

  • Unfortunately this didn't work for me. – Ryan Walker Jan 13 '14 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.