1

I'm tyring to configure AppFabric on Windows svr 2012 r2. I installed it my machine but when I try to run sharepoint 2013 prerequisites installer, it returns me a error. enter image description here

  • 1
    We have had at least two other questions regarding SharePoint 2013 and Windows Server 2012 R2. It is not supported to install SP 2013 on 2012 R2 until SharePoint 2013 SP1 is released! – Robert Lindgren Jan 8 '14 at 16:36
  • 1
    See: sharepoint.stackexchange.com/questions/85883/… . Your question is not a duplicate so it will remain open for now, but your answer is in that post – Robert Lindgren Jan 8 '14 at 16:37
1

AppFabric comes with the SharePoint prerequisites installer. Did you try to install it manually before running this setup? Try to uninstall it and re-run the prereqs installer.

Note: Appfabric installation and configuration has to be done by the prerequisite installer ONLY and not in a stand-alone manner.

You can implement any one of the two solutions listed below:

Solution 1: Append the following path to PSModulePath entry in the environment variables - %SYSTEMROOT%\System32\WindowsPowerShell\v1.0

◦Go to My Computer, right-click Properties

◦On the System' page, click Advanced System Settings on the left-side pane.

◦If you receive a UAC prompt, click on Yes to launch the System Properties dialog box

◦From the Advanced tab, click Environment Variables

◦Within the System Variables section in the lower half, select PSModulePath and click on Edit (or double-click PSModulePath')

◦Append the following path to PSModulePath entry in the environment variables

%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\

◦Ensure that the PSModulePath entry looks like this:

C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules

Solution 2

◦There are chances that other applications might be referencing the same variable and may fail if it is deleted. This is what we can do if solution 1 does not help.

◦Remove the PSModulePath entry from the 'Environment Variables' and re-run the installer. Once it completes successfully, ensure that the PSModulePath entry looks the same as mentioned in solution 1.

Source: http://blogs.technet.com/b/praveenh/archive/2013/02/22/sharepoint-2013-prerequisites-fails-with-msi-installer-error-code-1603-while-installing-appfabric-1-1.aspx

0

SharePoint 2013 will not support Windows Server 2012 R2 until SharePoint 2013 with Service Pack 1 is released.

0

[Solved] Kindly, follow the mentioned steps in this article to configure windows server AppFabric correctly
https://mohamedelkassas.wordpress.com/2014/06/14/windows-server-appfabric-is-not-correctly-configured-as-sharepoint-2013-prerequisites/

  • 2
    Quote the main aspects of the article as links tend to go down. – Paul Strupeikis Feb 15 '16 at 12:55
  • Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer – Benny Skogberg Feb 15 '16 at 13:16
  • Please don't add the exact same answer to this question, as you did on this one. Instead, try to specify your answer further to make it a better of this specific question. Thank You! – Benny Skogberg Feb 15 '16 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.