0

I have a SharePoint 2010 solution that I upgraded to SharePoint 2013 using Visual Studio 2013. The code will build just fine and I have taken steps to upgrade the CSProj files and Solutions files. When attempting to deploy the solution my development farm I receive 689 errors and two warnings. The warnings are that the 2010 SharePoint Assemblies (Microsoft.SharePoint and Microsoft.SharePoint,Security version 14.0.0.0) cannot be resolved. All the errors are related to files that I have deleted from the project. Also, Visual Studio 2013 tries to upgrade the solution every time I open it.

1 Answer 1

0

You should first try to download and install Visual Studio Office Developer Tools. This will ensure that all assembly references are automatically updated. You want need to do any manual changes in project files. And then you should look to change references to _layouts, controltemplates etc. I recently migrated two of my codeplex projects to 2013. I have detailed the issues I encountered in my blog:

http://sharepointnadeem.blogspot.in/2013/12/sharepoint-2013-upgrade-sharepoint-2010.html

2
  • That definitely helps. I realized that even though I had removed the files from the project I was still referencing some of the files in the package. I had to go into the package explorer and delete the references to older assemblies included in the WSP file. Jan 8, 2014 at 19:09
  • You can mark it as answer if you feel it wa helpful. Jan 9, 2014 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.