1

I have a folder in a SharePoint document library that has several column default values set.

When I upload a file to this folder, the columns get their default value as expected.

However, when I choose to create a new word document and word starts up, the columns are empty.

How can I make the default values apply when I create new documents?

Example of my problem: The "Project" value below should already contain the column default value of the folder. Example of my problem: The "Project" value below should already contain the column default value of the folder.

  • I could be mistaken but at this point I believe the default values aren't applied because the file hasn't been created yet. Once you save it for the first time it should populate defaults. Which version of SP are you using? Is the document being opened in the browser (through Word Services) or actually in Microsoft Word on your desktop? – thanby Jan 7 '14 at 15:46
  • I am using SP 2013 and document is opened through the browser but on the desktop client. The weird thing is that most other folders in this library get their default values applied at this point, without the need to save file. – SilvioDante Jan 8 '14 at 7:52
0

What I had to do was in your library settings > [Your Content Type] > Advanced > Edit Template. Modify the template by adding the default columns and save. This would need to be done on each of the document libraries (or saving a template locally and then uploading it to the respective libraries)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.