I am an IT intern and fairly new to SharePoint/InfoPath.

I am working on a form that has already been published to a SharePoint list and I was told to make it so that the person/group picker control was restricted to only one value. At first I thought this would be easy and just make sure that multiple selection is not checked under the control properties, however when I bring up the general tab I do not get the options for allowing multiple selection, choosing from all users or specific groups. The only option I have is max lines.

I have pulled up other forms that I have worked on (they are not published to SharePoint) and get the options I am looking for.

So my question is, do I have to set up the restrictions on this control before I publish it? I did try setting up rules on this control but they never worked out so any clarification on this would be greatly appreciated.


2 Answers 2


Try editing the SharePoint list settings in the browser. Open the list, go to List Settings, click the field name and select "No" for "Allow multiple selections".

Edit after clarification that this is not a list form:

The described behavior of the control leads me to believe that the form has initially been created with InfoPath 2007 and the people picker is in fact a contact selector (ActiveX) control as outlined here: http://www.sharepointassist.com/2009/02/27/adding-a-contact-selectorpeople-picker-to-an-infopath-form/

The people picker control was introduced in IP 2010.

Though you can open the form in IP 2010 and everything looks like IP 2010, the fact that the General tab of the control properties is not showing the commands of a regular people field suggests that it's not really a people field.

You can try to convert the form to 2010 as outlined in these two Microsoft blog posts:

Person / Group Picker Improvements in InfoPath 2010

Upgrading InfoPath 2007 forms with Person/Group Pickers to InfoPath 2010

  • Thank you for the fast response, (sorry I couldn't respond right away) I was a knuckle head when I made the original question, I should have said that the form was published as "form library" I am looking into this solution and hope to try it out some time tonight Commented Jan 6, 2014 at 21:51
  • Is this an InfoPath 2007 form? If so, the option does not exist, even if you edit the form with IP 2010. You never specified a version. It would make a difference.
    – teylyn
    Commented Jan 7, 2014 at 1:05
  • no I am working InfoPath 2010. I went through the library settings and prompted the field so it displays as a column and I can restrict that so only one name appears in the library but the form still submits when more then one name is selected Commented Jan 7, 2014 at 3:55
  • 1
    OK, you work with IP 2010 but if the form has been created with IP 2007 then the people picker will not show the newer (as in IP 2010) properties.
    – teylyn
    Commented Jan 7, 2014 at 6:57
  • see new suggestions in edited answer
    – teylyn
    Commented Jan 7, 2014 at 7:16

One way for your to achieve this would be:

  1. Create a new SharePoint Group (or you can use one existent already) Make sure the original People/Person field in itself (when defined in the underlying list) is only allowing selection from that specific Group.
  2. Put target User into the group at step 1.
  3. Refresh your form to get the latest updates from the underlying list.
  • 1
    I think the OP wants to switch from multi-value person field to single-value person field, and NOT restrict the pick list of persons to one person. So this approach will not work.
    – teylyn
    Commented Jan 6, 2014 at 20:04
  • Teylyn, it might seems so, but read through and his actually referring to being able to only select a single individual and he already tried un-checking multiple selections. Commented Jan 6, 2014 at 20:17
  • I see reference to "only one value" and unchecking "multiple selection", never referring to a single individual. He does not see the options to set these values in the people picker control dialog, which is peculiar.
    – teylyn
    Commented Jan 6, 2014 at 20:44
  • @teylyn you are correct in that I do not want to restrict the pick list to one person Commented Jan 6, 2014 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.