1

Ran into a strange problem today trying to import a custom design package using design manager. The solution uploads just fine but then i get an error:

Sorry, something went wrong

Value cannot be null.

Parameter name: g

TECHNICAL DETAILS

Here is the log file entry:

Error installing design package:

Design Package Install: an error occurred while installing package 'Spillman_Brand-1.4.wsp' at web /. Error: Value cannot be null. Parameter name: g Stacktrace: at System.Guid..ctor(String g) at Microsoft.SharePoint.SPUserSolutionCollection.Add(Int32 solutionGalleryItemId) at Microsoft.SharePoint.Publishing.DesignPackage.<>c_DisplayClass1.b_0() at Microsoft.SharePoint.SPSecurity.<>c_DisplayClass5.b_3() at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode) at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param) at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode) at Microsoft.SharePoint.Publishing.DesignPackage.Install(SPSite site, DesignPackageInfo info, Stream data) at Microsoft.SharePoint.Publishing.Internal.CodeBehind.DesignPackageInstall.<>c_DisplayClass1.b_0(SPLongOperation longOperation)

I tried uploading it directly to the solution gallery but it will not activate.

I also tried a different site collection and it works just fine.

Tried turning the publishing feature off and then on again.

Any ideas?

  • what is your feature scope? Try changing the feature scope to Farm or Site. – Mike Jan 6 '14 at 17:48
  • Is it possible to change the feature scope this way? I exported a design package and tried to import it to another site. Never saw an option for the feature scope. It also works on other site collections no problem. – Brad Jan 6 '14 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.