1

I was playing around with InfoPath and then i click on "Edit Form Code...". Now I am unable to publish the forms without getting "An administrator must approve this form temaplte before it can be fileld out by using a browser". Anyone know how to undo this.

Thanks

Solution found:

I used this to work it out.

  • List item

    1) Tools->Form options

    2)Programming->Remove code.

It also worked

1
  • Great that you found a solution! But please add it as an answer to your question, so you can mark it as the correct answer later on! Jan 6 '14 at 7:54
1

You will need to edit the manifest.xsf.

To get at the manifest file, click File > Publish > Export Source Files. Take note of the folder. Close InfoPath Designer. Navigate to the folder and open manifest.xsf with a text editor.

Look for a tag called xsf2:managedCode. It contains the link to managed code for the form. Remove the tag itself, but only that tag, and save the manifest file. (You also need to navigate to that location and delete the code project, but it won't affect the form any more).

Then right-click on manifest.xsf and select "Design" to open the form in IP Designer again. Save the form.

Now you can publish it without the warning.

2
  • Thanks. I used this to work it out. 1) Tools->Form options 2)Programming->Remove code. It also worked
    – mushi
    Jan 6 '14 at 3:47
  • That's a lot shorter and faster :)
    – teylyn
    Jan 6 '14 at 7:54
-1

Thanks.

I used this to work it out.

1) Tools->Form options

2)Programming on side bar-> click Remove code.

It also worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.