My InfoPath form web part remembers some false connections from the past, and cannot take any new connections after Save List as Template.

What I did is this:

  1. Customize Form in browser (SP2013)
  2. Edit the "New" form (which now has InfoPath form web part in it)
  3. Add a Query String Filter, and connect it to the InfoPath form
  4. Save List as a Template
  5. Create a new list based in that template. I edit the New form and notice that the Query String Filter is not there anymore (and thus it needs to be created)
  6. Check that the InfoPath form has all the connections grayed out (so apparently no connections exist?)
  7. Add a new Query String Filter on page, and try to connect it to the InfoPath form web part Now I get an exception that the consumer (InfoPath form web part) only allows one connection at the time. So apparently the connection is lurking somewhere there in the background.

How can I get rid of this extra connection?

1 Answer 1


The problem is that every list in the template get a new ID when the list is created during the template provisioning.

Therefor the filter and fields reference to non existing list. While the web parts reference the list via the url. The filter web part use hard coded ID's.

The only way around this is to reconfigure or add a custom code that fix the connections of the web parts.

  • Do you mean by reconfiguring to create a new template without filter web parts?
    – thomius
    Commented Jan 2, 2014 at 18:55
  • You can add the web parts but you shouldn't configure the connections in the web site you save as templates. After you provisioned a site from the template you can add the connections manually. Other option would be set the connection by activating a custom feature with a custom feature event receiver by code. Commented Jan 2, 2014 at 19:38
  • Also thinking about adding the filter with connection via CSOM remotely (but I'm not sure yet whether that will work)
    – thomius
    Commented Jan 2, 2014 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.