0

I have a developed a Sharepoint Site 2010 in my development server which has both SP and SQL in same server, whereas client production site has 2 tier setup, SP and SQL both in different physical servers. but when I restore my farm it is not restoring: Unable to connect Content DB.

How can we restore in this kind of scenario?

1

One option would be to use SQL Alias to "trick" SharePoint into thinking it's still using the same server as before. I've done this in the past and worked like a charm. This also a Microsoft best practice.

Step by step: http://technet.microsoft.com/en-us/library/cc512725(v=office.15).aspx

Simple SQL Alias example: http://blogs.msdn.com/b/priyo/archive/2013/09/13/sql-alias-for-sharepoint.aspx

Similar question: Move database to new SQL Server

0

What you want, move the site collection only?

there are 2 easy ways,

1)Take the backup of the site collection from Dev Farm Using Backup-spsits, then restore the site collection into prod using Restore-spsite

2) take the backup of the Content DB(via SQL) and move the Content DB to the production SQL Server. Now Attach the Content TO the web Application Using Mount content Db or from the Central Admin > Manage Content DB options

Before any Operation, Make sure both farms are same Build Level. if their is version mismatch it will fail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.