3

I have stumbled over a problem that doesn't seem to have a clear answer according to all documentation and forum threads I've found. According to this, http://support.microsoft.com/kb/2758431, in order to use SharePoint Designer 2013 with a SharePoint Server 2013 farm, I have to enable Anonymous Authentication in IIS. Am I reading this correctly or is there documentation that guides one to setup or repair SharePoint Designer 2013 to be able to connect to the 2013 farm and publish workflows using Windows Auth with Kerberos?

The situation is interesting since my SharePoint Designer 2013 has worked without enabling Anonymous Auth in IIS. I am using Kerberos with Claims on the main SP15 application and when I installed the Workflow Farm, I tested a workflow and it worked just fine. Yesterday, all of a sudden, I could not connect to the farm through SharePoint 2013, getting the "Object Moved" error described in the MS KB linked above in a weird cycle where this error keeps popping up and I can't get rid of it or use Designer unless I kill it on my client machine, enable Anonymous Auth in IIS, and reconnect.

What am I missing? I have a dev farm setup just the same way and I see the same behavior recently - very surprising since we have developed several workflows through SharePoint Designer 2013 on the dev farm, but now we can't access them without Anonymous Auth enabled in IIS.

Any info or ideas would be great. I cleaned up my SharePoint designer cache locally; also, the loopback errors and KBs needed to run run Desiger clean are no issues; I have not used Extended Protection in IIS, which is mentioned that could be a problem in other source. I am not running out of memory, not even close.

Thanks a bunch in advance, Radu

1

you don't enable anonymous in IIS you enable it in the central management

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.