7

I am working on sharing service applications across farms ( SP2013 Publishing Farm, SP 2010 Consuming Farm). Services like Search, MMS and Secure Store are working perfectly fine after sharing. However, Business Data Connectivity Service is not working. Following error is thrown when trying to create an External content type from SP 2010 Designer:

Event viewer shows following error: The BDC Service application Connection to: SP 2013 Business Data Connectivity Service is not accessible. The full exception text is: The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter http://www.microsoft.com/Office/2009/BusinessDataCatalog:GetThrottlingRulesResult. The InnerException message was 'Invalid enum value 'OData' cannot be deserialized into type 'Microsoft.BusinessData.SystemSpecific.ThrottleScope'. Ensure that the necessary enum values are present and are marked with EnumMemberAttribute attribute if the type has DataContractAttribute attribute.'. Please see InnerException for more details.

One of the entries in the ULS logs apart from the above is “No ThrottlingRules found”. So far I have tried following fixes without any success:

  1. Made sure all authentication methods except for Anonymous and Windows are Disabled for security token service in both SP 2010 and SP 2013 farm.
  2. Specified administrator for the service and given full control to it.
  3. Started “Request Management” service in SP 2013 farm. Not sure if it is needed. However, Request Management and Throttling rules seem to have a relationship with each other.
  4. Ran BCS throttle config Power shell commands in SP 2013 which also looks OK.

  • Just to rule out the obvious, did you confirm that BCS service (Central Administration > Application Management > Manage services on server > Business Data Connectivity Service) is running? – Slaven Semper Nov 15 '14 at 15:34
  • Yes. It was running. – Nadeem Yousuf Nov 15 '14 at 15:45
0

Try to re-create BCS service application if it is possible. Then I would recommend you to restart all servers in the farm.

  • I have tried that with no success. – Nadeem Yousuf May 19 '14 at 9:41
  • Which database are you trying to connect to? If it is an MSSQL database itself, then first try to connect to Management studio. If it is connecting successfully then add the same credential as a administrator of BDC application. – ateet Oct 6 '14 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.