3

I am working on one of my clients MOSS 2007 portal.
I can successfully take backup of site collection.
Since last few months we are getting Farm backup failed due to Search DB. I have few more problems related to the Search content DB. The DB size is near 150 GB. Details are below:
1) Below Error from Central Admin and from backup script also.

Progress: [Shared Search Index] 50 percent complete. Error: Object Shared Search Index failed in event OnBackup. For more information , see the error log located in the backup directory.
Object Shared Search Index failed in event OnPrepareBackup. For more inf ormation, see the error log located in the backup directory.
WebException: The current operation timed-out after 3600 seconds
WebException: The current operation timed-out after 3600 seconds Verbose: Starting object: Portal_SharedServices_Search_DB.
Error: Object Portal_SharedServices_Search_DB failed in event OnBackup. Fo r more information, see the error log located in the backup directory.
Object Portal_SharedServices_Search_DB failed in event OnPrepareBa ckup. For more information, see the error log located in the backup directory.
WebException: The current operation timed-out after 3600 seconds
WebException: The current operation timed-out after 3600 seconds

2) While taking taking backup from SQL we are getting error.
3) While truncating the DB we are getting error. [This point is Completed. Please see the update below.]
I searched alot on web but no success.
I worked with reset index but the error is exist.
I worked with Stop/start office search service with stsadm commands but error is still exist.
I need this backup but unsuccess. Please help.

Update:
the log file is 132 GB and this is giving problem.
Update: 7 January 2014
Truncating is completed. Set DB property "Single User" after truncating revert it back to "Multiple user". but db backup was not done. and now farm backup is hanged on "shared search index 50 percent complete".
Update: 5 Feb 2014
We are able to truncate the db using single user mode. but Backup issue is not resolved.

1

You can try to shrink the logfile for the SearchDB by changing the recovery model to "Simple" and then go to Tasks > Shrink > Files and select "File type : Log".

It´s quite possible that the log is just full of air as you have been taking backups regularly.

If it isn´t just air, you can take a SQL backup and then shrink the file. Try taking a farm backup after that.

  • is there any impact of this procedure? do we need to take down time? I would like to inform you that this site collection is having more than 300 sites. Most of the sites are having document libraries. – MAK Jan 3 '14 at 10:17
  • I would never do anything on a production environment "on hours" whatever the change. This shouldn´t affect anything though, atleast not the content you have. If anything goes wrong then something could happen to your Search database but reading from your comments I gather that you are just "this" close to rebuild them anyways ;) Stopping the Search Service would not be the worst idea though. – Funi Magnússon Jan 3 '14 at 10:35
  • What I can understand from your comment is we should stop Search service and take backup. We can stop search service but the search db will be there. On Farm backup it may give error. As we know the problem is in Search DB. Please correct me if I am wrong... Thanks. – MAK Jan 3 '14 at 10:54
  • Stop the SearchService (The DB will not disappear), go to SQL Management Studio and put the Database to simple recovery model, take a incremental backup and then shrink the logfile. Start the SearchService again and try to take a farm backup. Please note that Search will be unavailable while you are doing this and ,depending on your infrastructure resources, the SharePoint environment can get sluggish as this is CPU intensive operation. – Funi Magnússon Jan 3 '14 at 11:05
  • Using "set db property to single user", Truncating is completed. I have not taken backup. while taking backup the process was completed 100% and suddenly came to 0%. I stopped it and truncated the DB and started Farm Backup but now the Farm backup is hanged at "shared search index 50 percent complete". Farm backup is still having issue. – MAK Jan 7 '14 at 7:01
0

There are various reason for this failure. did you restart the Search server( on which search is running)?
also try to run the backup from different server using the script.
are search crawl is running at the same time when you run the backup?
what is the status of Search on the Search Admin page?

  • it is on the same server (SharePoint server). I rebooted the search server but no success. I stopped (Idle) the crawling and then taken backup but same error. **Status: ** Currently one of the content source is crawling. – MAK Dec 26 '13 at 5:21
  • you seeing the this error "Status: ** Currently one of the content source is crawling." correct, you need to fix this, it should be idle. try this link to run the restart script: blogs.msdn.com/b/jjameson/archive/2009/03/26/… – Waqas Sarwar MVP Dec 26 '13 at 20:44
  • **Status: ** Currently one of the content source is crawling. this is not an error. I given you the status of Crawler. the script you given to restart the SharePoint and SP search service which I have tried earlier. – MAK Dec 27 '13 at 5:43
  • i am saying, if you crawler status is saying crawling status then your backup will fail. so either let it complete and cancel and then run the backup. – Waqas Sarwar MVP Dec 27 '13 at 15:29
  • Should I idle the crawler and then take backup? can I remove remove the current db (145 GB) then create new one from fresh? what will be the impact? – MAK Dec 30 '13 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.