Well I :

Installed windows server 2008 R2 SP1 on vmware Virtual machine stand alone not in any domain

Installed SP 2013 Pre-requisites Installed SP 2013 succefully

running the configuration wizard after few steps i get this error

System.ArgumentException was thrown. Additional exception information: The SDDL string contains an invalid sid or a sid that cannot be translated.

found out that there could be a solution for this on http://social.technet.microsoft.com/Forums/en-US/sharepointitpropreview/thread/62704a0b-abf6-4b59-a7d5-c68d1e652fc2

but that is now taking to page not found

plz help

  • This was very helpful and it worked like a charm. I did have to install the snapin for sharepoint for PS in order to get the New-SPManagedAccount -Credential $SearchService command to work. After that it worked like a charm.
    – user52905
    Commented Apr 3, 2016 at 7:23

2 Answers 2


as you are installing as standalone, service running under Network Service account in workgroup environment is not supported.

check these two blogs and fix the issue.

http://kancharla-sharepoint.blogspot.com/2012/07/service-running-under-network-service.html http://kancharla-sharepoint.blogspot.com/2012/07/the-sddl-string-contains-invalid-sid-or.html


This forum article helped me but I have to substitute for the missing "C:\Program Files\Microsoft Office Servers\15.0\Data\Office Server" - C:\Program Files\Windows SharePoint Services\15.0\Data\Analytics_{some guid}

Hi All,

Recently an issue was reported to me where some of my site admins were facing an issue in setting up a SharePoint 2013 stand alone environment. They were facing this error in the step 8 of SharePoint configuration wizard "The SDDL string contains an invalid sid or a sid that cannot be translated".

After spending significant amount of time this issue was finally resolved in this way:

  1. Add the account you want to use for search service in WSS_Admin_WPG group. If you are going to use built in administrator account this should be present by default.
  2. Then execute this command from sharepoint powershell console: $SearchService = Get-Credential Domain\UserName in our scenario of standalone installation the Domain should be the machine name.
  3. Then execute this command New-SPManagedAccount -Credential $SearchService
  4. Now Go to "C:\Program Files\Microsoft Office Servers\15.0\Data\Office Server" and find the folder that starts with Analytics with a postfix guid.
  5. Right-click --> Properties-->Sharing-->Advanced Sharing
  6. Check the "Share this folder' check box and click on Permissions
  7. Add the Search Service account created in step 2 and select Full Control. Do the same for WSS_ADMIN_WPG
  8. Run the SharePoint Configuration Wizard again. It should now complete successfully.

Rahul Rashu

  • 1
    Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer
    – Benny Skogberg
    Commented Feb 7, 2014 at 14:36
  • I took 2 days to solve this error... until I found this, thanks for sharing Commented Oct 27, 2018 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.