SP2013 Enterprise, InfoPath 2013

I've built a form using InfoPath 2013 for a SharePoint 2013 list that includes two people picker controls for entering domain users. The fields these controls are bound to are just basic "Person or Group" fields.

The problem is that when any user filling out the form types a name into the picker, if they hit "Enter" to check the name it spits out a red error message below the control saying "The target [very long jumble of characters that includes the control name] for the callback could not be found or did not implement ICallbackEventHandler." But if the user then clicks anywhere on the form, the picker successfully checks the name and clears the message.

The form submits properly, but obviously we can't have the users seeing this nasty looking error message. I've done my research and the only instances of this online are of people making webparts by code, and the solutions don't apply to InfoPath.

I have tried completely deleting the fields from the list and form and recreating them from scratch but with the same result. This type of setup has worked perfectly in the past, the only difference I can see is that in this case is that the people pickers are not on the default view of the form, they have to be accessed by a button that switches to their respective views. I don't see how that could matter, but it's the only thing I can think of.

Does anyone know how to fix this error in InfoPath? Or at least can shed some light on the cause?

Edit: Per Diego's answer I have ensured the columns are set to pick people from all users, instead of from a group.

3 Answers 3


Check the "Column Settings" in SharePoint Designer. If the "Choose from:" is to "SharePoint Group" change it to "All Users".

  • Hm, tried that but it didn't change anything. Any other suggestions?
    – thanby
    Dec 20, 2013 at 17:29

Turns out it does have something to do with which view the people picker is on. I moved it to the default (edit) view and it works normally now. If someone has a better solution please post it and I will accept it instead.


I was having this similar issue with SharePoint/InfoPath 2010 and the people picker field throwing "There was an error with the callback" when the field would validate. It would occur when the people picker was on a secondary view and I switched to it to make a change. This sounded very similar to what was happening here and I would assume that the same solution I used would work here as well.

My Solution:
Since the control would render and act correctly when it was a part of the default view, I figured it must have something to do with it rendering on the page load. Therefore I added the people picker field to the default view and made it hidden. I loaded up the form, switched views, and the error no longer appeared on validation.

  • Now that's definitely a clever solution. I'm on 2013 of both so I'll have to try it out and verify.
    – thanby
    Feb 7, 2014 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.