9

Unable to open the site on SPD:

Sharepoint designer web server does not appear have Sharepoint foundation installed"

More Errors:

  1. The web server may not have sharepoint server installed
  2. The web server may be temporarily out of service
  3. If you are connecting through a proxy server, the proxy settings may be incorrect
  4. An error may have occurred in the web server

Note, I have ensured the "client integration is enabled".

Infopath is also throwing error:

The following web server does not appear to be running SharePoint

Steps tried:

  1. Rebooted the machine
  2. Reinstalled the SPD even though it is a farm level issue
  3. Rebooted the Servers
  4. Added the site into Trusted zone.
  5. Tried to select the edit on SPD from IE
  • It would be helpful if you captured fiddler or netmon trace of the attempt and attached to the question. – Alexey Krasheninnikov Dec 24 '13 at 6:39
  • I've seen a couple of cases where IIS was misconfigured and didn't serve appropriate HTTP headers. – Alexey Krasheninnikov Dec 24 '13 at 6:40
  • Hi Karthikeyan, I have posted some instructions below on how to resolve this. Please give it a try and let me know if it works. Thanks, – Haroun A. Dec 24 '13 at 18:25
10
+25

To resolve this problem, make sure the correct web application has client integration enabled.

To do this, follow these steps:

Start SharePoint 2010 Central Administration, and then click Security.

Click Specify authentication providers.

If the Web application in the Web Application list is not the same application that you want to open in SharePoint Designer 2010, click Web Application on the Change Web Application list.

On the Select Web Application page, click the name of the Web application that you want to open.

Under Zone, Click Default to open the Edit Authentication page.

Under Enable Client Integration, click Yes, and then click Save.

  • 1
    Another useless and stupid downvote without comments. I can't stand dumbass people downvoting without placing comments. This is the answer per Microsoft's recommendations. – Haroun A. Dec 25 '13 at 0:25
  • 1
    They only downvote for their own answer to be ranked higher. – Wout Dec 25 '13 at 8:56
  • Request you to check the question before answering, have clearly mentioned all the points that you've it in answer..! – Karthikeyan Dec 25 '13 at 15:39
  • 1
    Request you to read the entire answer clearly before downvoting. Also, request you to comment when down voting in order for users to understand and be able to properly assist you in a constructive way. Lastly, request you to edit your question to include and confirm that you have verified that client integration is enabled on the correct and specific web application in question here. – Haroun A. Dec 26 '13 at 16:46
4

as you mentioned you enable the Client Integration,

  1. Did you close the SPD after that and reopen it, or even try to restart the PC.
  2. Also try to add the site into Trusted zone.
  3. If above fails, try this.....Open SDP(but dont try to open Site)...Now Open Site in IE, once it loaded then try to open in SPD.
4

I had similar problem, but honestly, I'm not sure what exactly fixed the problem. I guess it was installing of last update for SharePoint. I know this is like repair clocks by hummer, but if there is not any other option =).

3

When I got this error message, the reason was that the SQL server was down. Make sure the SQL service is running and port 1433 (or whichever you chose) is allowed through the firewall.

1

I ran into the same issue.
In my case, it turned out that my web.config file wasn't 100% correct. After comparing the file with other web.config files, I located and fixed issue.

After updating the web.config file, SPD and InfoPath were both able to connect to the site.

0

Try enabling web integration (central admin, web app, Default and select 'enable client integration')

Also as mentioned above. Add the site to your trusted sites, using IE sign-in to the SharePoint site and then open SPD by using Site Settings -> Edit in SharePoint Designer.

Sometimes when my laptop is not member of the network I'm on. I also have to add the url to my Windows 'hosts file'. But this is more a networking / proxy issue rather than SharePoint.

  • Why is this downvoted? It is exactly the same as the 'answer'. – Wout Dec 25 '13 at 8:59
  • Request you to check the question, have clearly mentioned all the points that you've it in answer..! – Karthikeyan Dec 25 '13 at 15:37
  • 2
    The 'answer' is edited afterwards. My reply still contains extra information. I do not want to be marked as answer but down-voting here is just not appropriate and stupid. – Wout Dec 26 '13 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.