3

Here is what I am trying to do. I have a document library with a column called Manager. When a user uploads a document a workflow kicks off which then fills in the Manager column. This works fine. My only question is, when the user uploads the document, they are given a box that display the name of the document, title and the manager field... is there a way to get rid of this so or automatically fill in that manager field in the popup? I just want the users to be able to upload the document and not be prompted to fill in any information.

3

You can hide that field in NewItem form. One way to do that is with a PowerShell script

Enable Management of Content types in Advaced List Settings and Run the following script:

Add-PSSnapin Microsoft.SharePoint.PowerShell –erroraction SilentlyContinue
$web = Get-SPWeb -Identity http://....
$list = $web.Lists["ListName"];
$field = $list.Fields["FieldName"];
$field.ShowInNewForm = 0;
$field.Update();
$web.Dispose();
2

You can hide the manager field from the form. Go into Library Settings, enable management of content types in the Advanced settings. Then click the Content Type (which may be "Document" unless you are using a different content type), click the field that you want to hide and set it to "Hidden". It will now no longer appear in the form for the document properties, nor in the DIP when the document is opened with MS Office.

No code. Just a few clicks.

  • Thanks! That worked! Is there a way to just remove the popup dialog box and just allow them to upload the file? – gmatteson Dec 19 '13 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.