I have created a page layout and Content type in VS 2012. following is my code:

<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
 <!-- Parent ContentType: Artikelsida (0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF3900242457EFB8B24247815D688C526CD44D) -->
 <ContentType ID="0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF3900242457EFB8B24247815D688C526CD44D00EA76451DECA448F3942CC207FCA7D287"
           Description="This is test desc for temp"

here is the page layout.

<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
 <Module Name="PageLayouts" Url="_catalogs/masterpage/ranet" RootWebOnly="TRUE">
  <File Path="PageLayouts\PLaMtalat.aspx" Url="PLaMtalat.aspx" Type="GhostableInLibrary" Level="Published" ReplaceContent="true">
   <Property Name="Title" Value="Temp Page layout" />
   <Property Name="ContentType" Value="$Resources:cmscore,contenttype_pagelayout_name;" />
  <Property Name="PublishingAssociatedContentType" Value=";#AMtalat;#0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF3900242457EFB8B24247815D688C526CD44D00EA76451DECA448F3942CC207FCA7D287;#" />
   <Property Name="UIVersion" Value="15" />
   <Property Name="MasterPageDescription" Value="This is just desc for temp pl"/>

However when you go to pages library and choose Files in the ribbon and click on "New Document" the description of the Content Type still comes from Article Content Type. How can I change this description that shows up below my content type in pages Library when You choose New Document?

  • Are you sure that it's your Content Type and not the standard Article Content Type that's displayed in the drop-down list? In such case you would first need to add your Content Type to the List in List Settings, Content Types section. – Waldek Mastykarz - MVP Dec 18 '13 at 6:20
  • Yes I am sure. under content types section there are 4 content types, Page, ArticlePage, WelcomePage and Temp (my content type). – Medes Dec 18 '13 at 8:51

I need to recreate the site collection. I had added ReplaceContent attribute but changes were not take affect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.