0

I'm working on Sharepoint 2013 (Office 365 version) and until last week everything was normal. But from today the Content Search Web Part (CSWP) seemed to have started to show some unexpected behaviours:

  • When I add a CSWP to a page, I'm unable to edit it.
  • When I try to get the Snippet code from either the Master Page Snippet page or Layour Snippet page the properties iframe never opens.

Below some screenshots:

When I select CSWP When I select CSWP When I select other web part (it works) When I select other web part

Anyone come across with the same issue? Could it have been caused by something I did? (I've only been uploading display templates, layouts and CSS files and they've all been loaded without errors, and also mapping some managed properties to crawlable properties)

Edit: It seems to be working, although it takes approximately 10 minutes before anything appears on screen.

  • 1
    Does the CSWP behave the same way if you put it in a site with the default masterpage and no css modifications? – Vardhaman Deshpande Dec 16 '13 at 18:31
  • Yes, exactly the same. Just tried to be more patient, it seems it works but takes over 10 minutes before loading... – Joao Leal Dec 16 '13 at 22:04
  • Try configuring your cswp by csom powershell. FYI: We have the same behavior in our environmemt and we have opened a case with microsoft and they are working on it. – user21589 Dec 24 '13 at 11:14
  • How you tried stopping and starting the Distributed Cache Service? This sounds like the cache is not running, although it may appear to be started. – heatherglen Jan 7 '14 at 22:16
  • I think this must have been some Microsoft issue, since after Christmas it got back to a normal speed. – Joao Leal Jan 8 '14 at 12:49
0

This seems to have been fixed by Microsoft, since now it's back to an acceptable speed and as far as I know, our admins didn't apply any fix/change to the site collection configurations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.