2

I have created a document library declaratively with document based content type. But when I click on new document the icon is displayed of item instead of word.

Below is the example:

enter image description here

List tempalte is:

<ListTemplate
        Name="Documents"
        Type="11108"
        BaseType="1"
        OnQuickLaunch="TRUE"
        SecurityBits="11"
        DisallowContentTypes="false"
        Sequence="110"      
        DisplayName="QMSDocuments"          
        Image="/_layouts/15/images/itdl.png"
        DocumentTemplate="121"/>

<!-- Parent ContentType: Document (0x0101) -->
<ContentType ID="0x0101001EF0C163152340AE96F20234E13DC89B"
           Name="Docs"             
           Inherits="TRUE" Version="0">
<FieldRefs>
  <FieldRef ID="{44802E47-FE3F-4AB2-92BB-523A99E24B1D}" Name="DocTYpe"/>
  <FieldRef ID="{41F5A41B-BCC9-45B0-9CA5-48BB023713B8}" Name="Approver1"/>
  <FieldRef ID="{374F0F87-AFEB-4E88-A039-A3CADD24A5B1}" Name="Approver2"/>
  <FieldRef ID="{5DD956B5-65DD-4861-811F-42BE0C07B118}" Name="Author"/>
  <FieldRef ID="{257F1CC5-0DF4-420A-ACF1-8511FCD5240C}" Name="Chapter"/>
  <FieldRef ID="{2631BE05-A16D-4E41-948B-73F42D536705}" Name="ChapterNumber"/>
  <FieldRef ID="{7B08A524-E877-43C9-B8D5-A8143993B3B1}" Name="oiplbQmsDocumentSubject"/>
</FieldRefs>
</ContentType>

What should I do to dispaly the Word icon?

7
  • My Content Type that also inherits from Document gets the icon automatically, only difference in my Content Type xml is that I specify "Description" and Group" and specify Overwrite"TRUE". Dec 11, 2013 at 11:13
  • I will check by giving the attribute Overwrite and let you know
    – users1100
    Dec 11, 2013 at 11:35
  • Not sure why that would help though :/ Dec 11, 2013 at 11:36
  • Can there be something missing at other place?
    – users1100
    Dec 11, 2013 at 11:38
  • it did not work sir. :-(
    – users1100
    Dec 11, 2013 at 11:47

1 Answer 1

0

I think you have to deploy a document template with your contenttype

 <Folder TargetName="Forms/Docs" />
 <DocumentTemplate TargetName="DocumentTemplate.docx" />

The DocumentTemplate.docx can you deploy with a module.

You can also specify a documenttemplate manually. Open your contenttype > Advanced settings > Add your document template

1
  • Should not be needed. I have created a content type very similar to the one in the question, without document template, and I get an icon (not exactly the same as if I use a document template, but it do show a nice word icon) Dec 11, 2013 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.