I have a working wss3.0 + workflow solution, with some aspx forms (followed Robert Shelton’s tutorial) and some document libraries. I would like to deploy it with WSPBuilder but I have stuck hopeless.

The transformation of the workflow was 5 minutes, but I cannot transform workflow-forms at all. I have tried every way I found, but symptoms are constantly same:

The compiler at the codebehind file says "The name 'myAspxTextControl’ does not exist in the current context" for every control defined in the aspx file.

I tired to connect them on the following ways:

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Test.aspx.cs"
     Inherits="SWEF_WSP.Test, SWEF_WSP, Version=, Culture=neutral,
     PublicKeyToken=c935c51f6d8e9562" %>

...where SWEF_WSP.dll is my WSPBuilder projects assembly, SWEF_SWP is the namespace, Test.aspx and Test.aspx.cs are my form files demonstrating the issue.

I tried it with and without Codebehind field, and using separate @Asssembly directive too, and changed the the place of these files (in the Layout folder in 12 hive or not ), together, or not, the error is same.

I followed http://www.greggalipeau.com/2008/05/23/moving-a-sharepoint-workflow-between-solutions/ (and some more) but unfortunately didn’t find any buildable example.

I must be missing something very evident, any help would be greatly appreciated ...


This can happen if you somehow lose, or never created, the auto-generated partial class (e.g. Test.designer.cs).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy