0

SharePoint 2013 new farm that was created using the autospinstaller scripts. It is installed with August 2013 CU.

When a user navigates to his Doc Library in his Mysites (Skydrive pro) link, he is not able to add any documents or view document library settings. On logging in as admin to that site, I found out that the 'Documents' library in MySites (which is 'SkyDrive Pro' link) has unique permissions and is not inheriting permissions for the personal site collection.The unique permissions are empty, there is no permission to anybody. I changed it to inherit from the parent site and it worked fine for that user after that. I found this odd, so I checked this for few other personal sites and found the same issue.

Why is this happening that the Skydrive Pro library is having unique permissions ?

Is there any setting in the MySite host or anywhere else that does this ? or a bug in August CU ?

1

It is solved now.

The problem was with only that one user's personal site. I deleted that personal site and forced it to recreate and now the user is the site collection admin.

I do not know why the issue occurred, but there is no problem with other user's personal sites. The fact that the user will be the site collection admin of his personal site helped me solve the issue.

  • I've the same problem, no rights to the Skydrive Pro. How did you exactly delete the site? I did it via delete profile form SharePoint in the Office 365 site. regards, Peter – user23698 Feb 14 '14 at 18:10
  • This was OnPrem, so I deleted it by going to the 'Delete Site Collection' link and deleted the user's site collection under the MySite Web application. For O365 there must be a similar link where you can delete a site collection. – suhas Feb 16 '14 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.