I installed march 2013 CU for Sharepoint 2013 and after that I get:

Failed to call GetTypes on assembly Microsoft.Office.TranslationServices, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c. Method not found: 'Microsoft.Office.Web.Common.ProcessImageInfo Microsoft.Office.Web.Common.EnvironmentAdapters.IImagingAdapter.ProcessImage(System.IO.Stream, Double, Double)'.

What is this? I see it is related with the machine translation service. I checked this service and it was run. Since I don't use it I deleted this service. Now I get this error everytime I try to do smth on central admin

EDIT By delete I mean: I went to central admin -> Manage Service applications -> Selected Machine Translation Service and deleted.

But if I try to recreate using CA it gives this error.

1 Answer 1


you shouldnt delete a service becasue you dont use it ;), you should go into services and disable it if you belive that you dont use it!

have you tried iisreset? or restarting your server? i presume its a test server? also as important when you say you removed it, what did you do exactly to remove the service? are you talking about services.msc? or from a folder or from central admin? knowing what you did we can add it back in and solve the current issue.

also like to note that have you updated sharepoint server to october? or is it only at march update? if so you need to update it to the latest version, you need the march update to update to any other latest update!


its indicating that your using a build version of on assembly Microsoft.Office.TranslationServices but it should be at a higher build.



now find the assembly Microsoft.Office.TranslationServices and right click, select properties and than check its build version! I think the build version is ment to be higher than just

a bit about the service you removed:


lets see if you can get it running again:

run the following in powershell:

$tj = get-sptimerjob "Sharepoint Translation Services"


did you run SharePoint 2013 Products Configuration Wizard after the update? any update you make you need to run SharePoint 2013 Products Configuration Wizard.

if that powershell code fails than you need to run:

installutil assemblyname.exe

assemblyname.exe is the dll name of Microsoft.Office.TranslationServices located within C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.Office.Web.Common\v4.0_15.0.0.0__71e9bce111e9429c\


when its successful you can then go into services and disable not delete ;).

to sort the original issue out you either run microsoft office repair or sharepoint 2013 repair

for sharepoint 2013 repair

Control Panel -> Programs and Features for SharePoint Server 2013

any issues run powershell command from here:



based on the answers you have given me i would say that there is a conflict between central admin that is looking for dll version and what you actually have on the file system which is 15.0.4505.1000 and obviously its failing when its looking for a method that doesnt exist in the new version which you have!

to try and get around this issue as you cant seem to add the service back in you could try going to central admin web.config:


goto the above location and then go into the central admin folder (usual named from its port number which you can see in the url of central admin page)

once you have opend it up you can scroll down till you see the web.config file, open it with your selected text application like notepad or notepad++ and look for the dll Microsoft.Office.Web.Common.

once you have found the dll Microsoft.Office.Web.Common you can change the buil version from to 15.0.4505.1000. now save and exit.

do an iisreset and try to add the service back in again! lets hope this simple trick works!

  • Edited the question and yes it is a test environment
    – MIlena
    Dec 4, 2013 at 10:21
  • ok iv got more of an understanding of what you have done makes it easier to know what todo! so what did you do to try and add it back again? through powershell?
    – Ali Jafer
    Dec 4, 2013 at 10:29
  • i presume that you used powershell and that you used the ui by clicking on the new button and selecting the service in question? if so as iv noted above make sure that your dll is the correct version first
    – Ali Jafer
    Dec 4, 2013 at 10:39
  • I've tried to recreate the service running the configuration wizard but this error is displayed.
    – MIlena
    Dec 4, 2013 at 10:43
  • 1
    I can't find the Microsoft.Office.Web.Common on web.config for the Central Admin Web App
    – MIlena
    Dec 4, 2013 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.