Currently, I need to develop a workflow with looping feature and I googled that it is available in SharePoint 2013 workflow. But, when I tried to create a workflow for SharePoint 2013 in SharePoint designer, it shows a message saying:

"The option for the SharePoint 2013 Workflow platform is not available because the workflow service is not configured on the server. Please contact your server administrator."

enter image description here

I tried the following commandlets in powershell running as administrator after installing workflow manager 1.0, but unfortunately none worked:

Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl [says: Already configured]


Register-SPWorkflowService –SPSite "http://myserver/mysitecollection" –WorkflowHostUri "http://workflow.example.com:12291" –AllowOAuthHttp [throws error]

So, how can I configure for workflow 2013 in sharepoint designer 2013?

  • am also facing this issue, even after performing all the steps that required for wf install/configure.
    – samolpp2
    Commented Feb 12, 2017 at 2:47

6 Answers 6


what version of sharepoint are you using?

The steps in this article apply to SharePoint Server 2013. The SharePoint 2013 Workflow platform is not supported in SharePoint Foundation 2013.

goto Configure Workflow Manager to work with the SharePoint Server 2013 farm within the link below.


above is step by step tutorial to get it working!

iv noticed that your doing part of the step posted in the link! what error are you getting when running the powershell script?


you still havent told me what error your getting within the powershell script?

if its because its already bound than use force! the spsite is the site collection you want to bind the workflow service too, the WorkflowHostUri is the workflow service url where it resides, goto iis and find the workflow service under sites and see the url by browsing! copy the url into the powershell command below, the spsite you could do the same or just navigate within your browser to the site, copy the url and past it below:

Register-SPWorkflowService -SPSite 'https://myhost/mysite' -WorkflowHostUri 'https://workflowhost' -AllowOAuthHttp -Force

as per your example it would be:

Register-SPWorkflowService -SPSite 'https://sharepoint.example.com' -WorkflowHostUri 'https://workflowhost:23302' -AllowOAuthHttp -Force

'https://workflowhost:23302' is NOT central admin, its a url pointing to the workflow service, this url is found within iis manager under sites.

look at the image below under sites you can see the workflow site, right click and then browse

enter image description here

follow this trouble shooting guide for workflow service!



ok looks like were getting somewhere! ;)

looks like the workflow manager hasnt been installed properly! as you should see the site and the service within the app pool under iis manager!

you need to follow this guide http://technet.microsoft.com/en-us/library/jj193478 go through each stage carefully!


If you belive that the setup is fine than skip part 1 and goto part 2 instead to make sure you have setup the wrokflow farm correctly!


the stages are:

1) install


2) Open the Start menu.

In All Programs, go to Workflow Manager 1.0. Click the Workflow Configuration shortcut to start Workflow Configuration Wizard.

now create the farm (workflow farm ;) ):


3) verify workflow config!

1.Go to Start. Right click Computer and click Manage.

2.Expand configuration.

3.Click the Services.

4.Ensure that the entry in the Status column reads Started for the workflow services.

If this service is not yet started, right-click the service name in the Name column and click Start.

4) now carry on with the url i posted earlier to get it working with sharepoint!


as per your example it would be:

Register-SPWorkflowService -SPSite 'https://sharepoint.example.com' -WorkflowHostUri
'https://workflowhost:23302' -AllowOAuthHttp -Force

Even I faced the same issue previously. though workflow manager and all other stuffs were configured properly I was not able to see SP2013 Workflows in sharepoint designer as well as in other list and libraries.

Solution : whenever a new workflow service application proxy is created in SP2013, by default it will not be associated(service connection) with any web application. Go to Central admin site->Manage web applications page -> Select the web app which was registered earlier during configuration and check " workflow service application proxy" and click OK

  • Have all the configurations mentioned is this thread.. however I cannot see the VS 2012 deployed workflow listed in the Add a workflow page.
    – Muhammedh
    Commented Jun 11, 2014 at 11:37

You must give the Workflow Manager Process Identity Membership in local Group IIS_IUSR and gibe write perms to Windows Temp-Dir.


I had similar troubles and I got an error while running the Workflow Manager Configuration Wizard after step "Add host to Wokflow Manager Farm." and "Configuration Operation successful." For Fixing, I installed Service Bus Cumulated Updates 1 and then Setting up the farm again by using WMCWizard and it worked fine!


This worked for me:

1) Make sure the Workflow Manager Client is installed on ALL the farm servers. 2) If you have already registered with your SP2013 farm and designer is not showing it, then perhaps re-registering with a different -Scope option for Register-SPWorkflowService might help

  • What do you mean with different Scop option? What exactly is wrong? Commented Jan 26, 2017 at 12:39

Here is the Solution :

Modify your Powershell command as;

Register-SPWorkflowService –SPSite "http://abc:1255/" –WorkflowHostUri "http://abc:12291/" –AllowOAuthHttp
  • Why are you using that port? Trolling? Commented Jan 26, 2017 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.