3

Today I'm seeing some records on the ULS Viewer Logs. I see this message of high priority

[Forced due to logging gap, cached @ 12/03/2013 09:39:25.00, Original Level: Verbose] SQL connection time: 0.0602

And it occurs really often. Is this normal?

Checked ULS and an error appears now

Unexpected query execution failure in navigation query, HResult -2146232060. Query text (if available): "BEGIN TRAN DECLARE @abort int SET @abort = 0 DECLARE @EidBase int,@EidHome int SET @EidBase = 0 SET @EidHome = NULL IF @abort = 0 BEGIN EXEC @abort = proc_GetWebNavStructNodeByIds '6384D8A2-94E9-4FEE-82AA-684D9A6669B4','77AA6E79-3A82-4DE6-9EAE-C1E3CF2C67E2',3517 SELECT @wssp0 = @abort END IF @abort <> 0 BEGIN ROLLBACK TRAN END ELSE BEGIN COMMIT TRAN END IF @abort = 0 BEGIN EXEC proc_UpdateDiskUsed '6384D8A2-94E9-4FEE-82AA-684D9A6669B4' END "

3

its a logging feature found in the core.js, its a form of timout exception(but not really an error) its sent before logging any info.

For your situation its todo with somthing else! is your site going slow? have you created anything recently? you need to find the site its come from and then the page and delete it and recreate it and the message will disapear! you get this error after every missed 50 milliseconds i belive and this will run slowing down the site.

you should see below the error you posted another error detailing where its faulting! can you post that?

EDIT

Based on my understanding is that its running into a deadlock! from the error you posted its refering to a stored procedure that is failing and its in a constant loop and then times out which inturn runs the timout function in core.js!

This issue was resolved within 2010 but looks like its back again in 2013 lol, this can occure from a stored procedure that is say ment to return an int value but instead returns null or could be from offending repeating urls where its listing (waiting) for one stored procedure on sql server that is in lock position and that same locked stored procedure is also waiting for that other stored procedure so you have a deadlock on a table that is not returning the correct results back causing timeouts!

there are two options! one is to update sharepoint 2013 using the hotfix april cu 2013:

note that its a hit miss with people!

http://blogs.technet.com/b/stefan_gossner/archive/2013/04/27/april-2013-cu-for-sharepoint-2013-has-been-released.aspx

you can run a script but it also has a mixed bag with the result being that it delets wanted navigation that you would need to out back together!

or the simple method of trying:

  • Navigate to the content and structure (Site settings > Manage content and structure)

  • delete the affected sub sites

  • restore them back from the site collection recycle bin (Deleted from end user recycle bin)

script can be found here with a detailed expo on the issue:

http://blogs.msdn.com/b/joerg_sinemus/archive/2013/02/12/february-2013-sharepoint-2010-hotfix.aspx

| improve this answer | |
  • Hello, this question might sound stupid but i'm asking: should this message appear if I create another brand new web application? I mean in the ULS Viewer appears: "Forced due to logging gap" and the "Name" field of ULS Viewer points to the new web app page url – MIlena Dec 3 '13 at 10:53
  • its worth a try! it could be related to the content database for that specific web application, but im persuming that the issue is deeper than that and has todo with a bug within sharepoint itself and how its communicating with sql server and how sql server is getting the data from the table as your hitting a constant loop within sql server. – Ali Jafer Dec 3 '13 at 11:09
  • I'm installing updates but it takes time. I'll let you know for the progress PS: I run the script to check the navigation nodes and the error doesn't persist anymore. But the message "Forced due to logging gap" is still present. For this reason I started to install updates that you suggested – MIlena Dec 3 '13 at 16:26
  • Seems like the problem is not present anymore, but another error appears when tried to use central admin, and update general settings for an web app. Failed to call GetTypes on assembly Microsoft.Office.TranslationServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c. Method not found: 'Microsoft.Office.Web.Common.ProcessImageInfo Microsoft.Office.Web.Common.EnvironmentAdapters.IImagingAdapter.ProcessImage(System.IO.Stream, Double, Double)' What is this? – MIlena Dec 4 '13 at 8:55
  • just answered the question which you asked today sharepoint.stackexchange.com/questions/84284/… i presume that your happy with this question and issue? – Ali Jafer Dec 4 '13 at 10:12
1

Quick Fix

I fix this issue by locating the published file in the ULS-log, which has been duplicated itself and causing a deadlock (the bug), which in our case made the entire Web Application unaccessible. MySite was still up and running. Find the file in SharePoint Designer, restart IIS and the problem is gone.

Solution

Next step for us (and others) is to install cumulative update (in our case October 2013 update) and the problem will be solved permanently.

| improve this answer | |
0

Googling the error, found a couple of sites useful. It seems to use a lot of CPU, so the fix should be in order.

Cite from the first link:

This can happen when a user has published a page with data calls of is really heavy and chatty data connection and/or may include large graphics. I also see this when users publish documents linked to RSS feeds that have second by second calls.

Resolution: Either delete the pages in question or ask the user to redesign the page. A IIS reset is not necessary, but it wont hurt.

MSDN link.

SharePoint Thinking blog.

| improve this answer | |
  • I've seen these articles, but this is not a solution. Before, it was ok. This message appears even on sharepoint pages ex: /_layouts/settings.aspx – MIlena Dec 3 '13 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.