0

Running a SP2010 with Project Server 2010.

I can access my Central Admin

enter image description here

But when I try to connect to the server's Database from an SQL 2010 Management Studio, I can't.

The server's service is:

enter image description here

And log user is: Network Service

Error on the SQL Admin: enter image description here

The SQL configuration is:

enter image description here

  • TCP is enabled for clients as well

any ideas?

  • The SQL Servername is SHAREPOINT, is that what you are using? – Robert Lindgren Nov 26 '13 at 14:26
1

Not sure what you mean "log user is: Network Service"... Are you trying to log in as the Network service?

At any rate, I would try to disable the Named Pipes protocol, restart the SQL service and try again? But please dont try it if this is a producion server :) It will cause a service outage for a few seconds.

Are you referencing the server name when you try to connnect? Can you verify that the name resolves into the right IP address?

  • The log-on user is the Service Logon user set in services. Named pipes gone - all is working. – Saariko Nov 27 '13 at 7:17
1

You have instance called SHAREPOINT. If it is a local SQL Server, you can try to connect "(local)\SHAREPOINT" as server location / name when connecting with SQL Admin / SQL Management studio.

  • Thanks - it's a stand alone installation that uses the local SQL express - no local management studio is installed - and I don't want to install the Express MS. – Saariko Nov 27 '13 at 7:14
1

The error suggests you cannot connect remotely, so first step is to connect to the database through SQL Server Management Studio locally.

There are three things you can check.

The first is that the TCP/IP service is enabled (you've done that already.)

The second is that remote connections are enabled. To check this, right click on the database server in SSMS and choose properties. Then go to the connections tab and ensure that the "Allow remote connections to this server" is checked off.

Finally, you have to make sure that the firewall on the SQL server machine is allowing inbound connections on the SQL server port (1433). How to do this is dependent on what firewall you have installed.

Source: http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

Also important to consider:

Is SQL server running on a different server than SharePoint, and can SharePoint access the database? If both of these are true, than it means that it is possible to access the database remotely, so the next place to look would be why you personally can't connect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.