1

I have a couple of nested site collections e.g.:

Is there a SharePoint/ASP.NET control that could display the name and URL of the Portal Site Collection (Intranet). I am not looking for a code solution but for a control that I could embedded intro master page as part of breadcrumbs trail e.g. Intranet > Sales > Telesales

2

For a no code solution, you could try building a custom sitemap

http://blah.winsmarts.com/2008-1-Implementing_Consistent_Navigation_across_Site_Collections.aspx

<siteMap>
  <siteMapNode title="Intranet" url="http://intranet">
    <siteMapNode title="Sales" url="http://intranet/sites/sales">
    </siteMapNode>
    <siteMapNode title="Marketing" url="http://intranet/sites/marketing">
    </siteMapNode>
  </siteMapNode>
</siteMap> 

Then set the SiteMapProviders for your breadcrumb control.

<asp:SiteMapPath
    runat="server"
    SiteMapProviders="SPSiteMapProvider,SPXmlContentMapProvider"
    RenderCurrentNodeAsLink="false"
    NodeStyle-CssClass="breadcrumbNode"
    CurrentNodeStyle-CssClass="breadcrumbCurrentNode"
    RootNodeStyle-CssClass="breadcrumbRootNode"
    HideInteriorRootNodes="true"
    SkipLinkText=""/>
1

Have you tried configuring the Portal Site Connection in the Site Collection Administrators setting for each site to point to the "Intranet" site? I'm a little rusty on this, but I think that in SharePoint 2007 that would set the breadcrumbs up to work properly with the Portal as the top-level site for the navigation.

Based on what I'm seeing here, I would expect that to work the same way: http://technet.microsoft.com/en-us/library/cc263357.aspx.

John

  • Sure I did that, but it does not show. Maybe I am using wrong breadcrumbs control, but tried a couple of them and it seems neither will show it. – Toni Frankola Jan 10 '11 at 21:56
  • You need to change few lines in master page in order to get it work in SHarePoint 2013. Looking for <div class="ms-breadcrumb-dropdownBox"> remove the "style="display:none" and another "Visible= 'false'" in below. – YogaPanda Mar 28 '16 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.