1

When deploying a Workflow enabled app from Visual Studio (2012/2013), receive the error "MTW Client is invalid". More of the same error in the ULS logs.

SharePoint 2013 designer Workflows deploy and run successfully.

Additionally, found these errors in the ULS logs:

Microsoft.Workflow.Client.ScopeNotFoundException: Scope '/SharePoint/default/4b83fcb9-1856-4c09-a710-f200fbbebdb7/d2ca60f6-1118-41de-8585-c913de1628ec' was not found.  HTTP headers received from the server - ActivityId: c85e6f54-2b1a-40ea-9a47-5bd949c27bd4. NodeId: D1S2008R2WF1. Scope: /SharePoint/default/4b83fcb9-1856-4c09-a710-f200fbbebdb7/d2ca60f6-1118-41de-8585-c913de1628ec. Client ActivityId : 34d7efbe-e6f3-4c83-bd32-26d331eec32f. ---> System.Net.WebException: The remote server returned an error: (404) Not Found.
 at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)
 at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)
 at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
-- End of inner exception stack trace ---
 at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
 at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)
 at Microsoft.Workflow.Client.ScopeManager.Get()
 at Microsoft.SharePoint.WorkflowServices.ExternalSubscription.DeleteServiceGroup(String scopeAddress, String name, ICredentials credentials, Boolean isER, Boolean force) StackTrace:  at Microsoft.Office.Server.Native.dll: (sig=b9944ebb-0ede-47fe-ba7c-79e940e3c2c5|2|microsoft.office.server.native.pdb, offset=131CE) at Microsoft.Office.Server.Native.dll: (offset=21BFD)  34d7efbe-e6f3-4c83-bd32-26d331eec32f

System.InvalidOperationException: MTW client is invalid
 at Microsoft.SharePoint.WorkflowServices.DGWorkflowDeploymentProvider.ValidateClient()
 at Microsoft.SharePoint.WorkflowServices.DGWorkflowDeploymentProvider.Deploy(WorkflowScopeIdentifier scopeId, SPWorkflowPart parts, Dictionary`2 listIdDictionary)
StackTrace:  at Microsoft.Office.Server.Native.dll: (sig=b9944ebb-0ede-47fe-ba7c-79e940e3c2c5|2|microsoft.office.server.native.pdb, offset=131CE)
 at Microsoft.Office.Server.Native.dll: (offset=21BFD)  34d7efbe-e6f3-4c83-bd32-26d331eec32f

Please help!

  • Have you tested this with Workflow Debugging enabled/disabled in VS? – Trev M Nov 27 '13 at 2:02
  • I have not, I will give that a shot. Thanks for the tip. – Dylan Berry Nov 27 '13 at 13:59
  • Update: Issue is still unresolved. Visual Studio issues have been ruled out as the same error is encountered when deploying an app package. Microsoft support has been engaged for a week and a half and has not yet identified the root cause. – Dylan Berry Dec 8 '13 at 22:19
1

From http://social.msdn.microsoft.com/Forums/sharepoint/en-US/6406252a-d49e-4d9b-9bd4-f03ce0697708/app-workflow-mtw-client-is-invalid?forum=appsforsharepoint:

"Did you already fully configured the Workflow Manager on the server?

  • Register-SPWorkflowService

  • Open workflow manager port in the firewall. I think the URL of the workflow Manager must be accessible locally. That means you should see a XML result if you launch the URL."

  • Workflow Manager has been fully configured on the server and is locally accessible. – Dylan Berry Nov 24 '13 at 22:02
  • Additionally, SPD workflows function as expected. – Dylan Berry Nov 24 '13 at 22:03
0

I worked with Microsoft support to resolve this issue. It ended up being a problem with the Workflow Manager 1.0 Cumulative Update (http://support.microsoft.com/kb/2799754). Once the CU was reapplied, Workflow worked without issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.