While configuring cumulative updates for SharePoint 2013 on App and WFE Servers can we install CU on both App and WFE servers simultaneously? Or we should complete the installation on App Server first and then move to the Web server?

I'm already done with the March Update and first installed the update on App Server then did the same on Web Server. PSConfig executed successfully and now I am going to install October CU. However, in order to save time can we configure CU on both at the same time. Will it cause any issues or problems?

What would be the safe and correct approach?

When you install the bits, SharePoint will run that particular server in deprecated mode until the PSConfig.exe is successfully run on that server. It is ok to run the install part which just copies the bits to the server, on all servers at the same time. One the bits are on the servers though, it's standard and recommended best practice to run the PSConfig.exe on each server consecutively. Running PSConfig on multiple servers concurrently will cause one of the sessions to incur errors. Furthermore, it's important to run PSConfig on the app server where you have central admin running, first. Once that server completes without error, proceed to each additional farm server in turn. Be sure to check the upgrade log for each to ensure there are no errors.

Install CU at the same time in both servers. But best aproach, is run psconfig util in application server at first. Than run PSConfig at front end.

NOTE: Install CU on the test environmenment first!
Install CU only if this update provides hotfixes for YOUR trouble.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.