1

When I try to add a video to video library (New Document>Video), after select the video, it gives me this error. What should I do?

Working on it...

This shouldn't take long.

Server Error in '/' Application.

Runtime Error Description:

An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a tag within a "web.config" configuration file located in the root directory of the current web application. This tag should then have its "mode" attribute set to "Off".

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's configuration tag to point to a custom error page URL.

  • There is a lots of web.config file in LAYOUT folder. I couldn't find where the right one is. I don't want to make anything wrong. And I didn't understand why this error started to show up. Because I didn't edit any default code. – e.ozmen Nov 22 '13 at 8:50
  • There is 2 web.config files. One of them in the <port of webapp>, and the other one in the <port of webapp>/wpresource. Which one is needed to modify? – e.ozmen Nov 22 '13 at 9:08
  • It is Off. Here is some part of the web.config. <system.web> <httpHandlers /> <customErrors mode="Off" /> <httpRuntime maxRequestLength="51200" requestValidationMode="2.0" /> <authentication mode="Forms"> <forms loginUrl="/_login/default.aspx" /> </authentication> <identity impersonate="true" /> <authorization> I alse add mode="RemoteOnly" defaultRedirect="mycustompage.htm" . But it didn't work also. – e.ozmen Nov 22 '13 at 9:16
  • let us continue this discussion in chat – Ruben Herman Nov 22 '13 at 9:20
1

Always check your filesize when uploading large files. The default maximum upload size is 250MB, but can be changed in central administration (-> application management -> [your webapp] -> general settings -> maximum upload size)

For a powershell cmd: http://sharepointrelated.com/2012/07/30/maximum-file-size-per-extension-in-sharepoint-2013/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.