1

Recently we have migrated from SP2010 to SP2013. In our portal, i am seeing a issue with noteboard webpart, that is, wherever the noteboard webpart is placed the site layout got messed up. After analysis, I have found that the issue is due to missing/adding some div's in noteboard webpart. I don't how to solve this, Can any one help on this please?

I am assuming this is due to noteboard webpart, because after removing it, everything was fine.

1

This is a known issue with this webpart.

My solution in the past has been to create a custom webpart, where i add the SocialComment control and also a literal containing then missing end div.

  • Thanks for the quick reply. Hope you have the same issues SP2013? because it was fine for us in SP2010. Currently we have lot of existing content using outofbox noteboard webpart, so cannot create a custom webpart. Any other possible way to for this problem? – Sivakumar Nagasamy Nov 17 '13 at 15:12
  • You could possibly add some JavaScript in master page et.c. looking for this Webparts (not sure how you could identify it though) and add the missing div to the dom – Robert Lindgren Nov 17 '13 at 18:38
  • Adding the missed div cannot be achieved through the javascript, as once the document is rendered, we cannot add false html into dom, even if we try adding div and miss the close tag, js will add the missing div and then only it render. And moreover it is not the standard way, i suppose :( . Now i have to edit the noteboard's raw code or else i have to remove it from all pages with powershell. Can you help on this? – Sivakumar Nagasamy Nov 18 '13 at 11:27
  • As I said, my solution was th wrap the webpart in a custom one, then add a literal with the missing end div to the Controls collection. – Robert Lindgren Nov 18 '13 at 11:38
  • i cannot use custom one now, as i already had this OOB frature in many pages(>5000). So currently i have solved this using a usercontrol which adds the missing div in the noteboard, if that webpart exists in current page. Still i have one limitation, that is, i should keep the noteboard always in the bottom of the webpart zone, Luckily i had it. Thanks a lot for your advise. Do you have any idea whether this is already brought to microsoft's attention? – Sivakumar Nagasamy Nov 19 '13 at 5:02
0

Please verify that you have no self closing div's in your web part, like . If you do then replace them with

  • @Yevgeniy.Chernobrivets Yes dude verified. I have no such mistakes :( – Sivakumar Nagasamy Nov 17 '13 at 15:15
0

So the best way to overcome this issue, until we get the new patch from Microsoft, is to add the missing div in any ways.

Global solution is to create a custom web part which includes the NoteBoard webpart and a addiotional missing div "" to it Robert Lindgren suggested.

Else add the missing div somehow below the noteboard web part dynamically like me.

  • So, what I said basically ;) Feel free to mark it as an answer. – Robert Lindgren Dec 2 '13 at 9:28
  • @Robert Lindgren i tried to mark that as answer but i couldn't as i am very new to this forum and forum expects atleast 15 reputation point to vote. If i can do something, please let me know. And actually i thought giving a new answer may do this, but not :(. If you can mark as answer, please help. – Sivakumar Nagasamy Dec 2 '13 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.