I am using Managed Property in my application, it's a custom column in my site collection, I could make a managed property and link this to the crawled property and everything is ok. Now in my application, I am returning data using xml like this: http://lh5.ggpht.com/-vRX9npffnMU/UOmVDkYNhuI/AAAAAAAAB1E/sWQ1uO4-mws/s1600-h/SearchRESTCallResults4.png and getting the exact property using: result.Cells.results[3].Value and so on.. but the managed property doesn't appear in the xml, and I don't know the index of this property. What should I do?


Try adding your custom managed property to the SelectProperties attribute in your Rest query against the search API.

Also make sure your Managed Property is marked as Retreivable in the search service application.

Microsoft has great documentation regarding using the search Rest API here: http://msdn.microsoft.com/en-us/library/office/jj163876.aspx

  • Hi Robert, Thank your, it's marked as Retrievable, but I don't see it in the list of properties returned in the xml, how do I use the SelectProperties? will it add the property to the xml? thanks – SharePoint Freak Nov 16 '13 at 17:59
  • The link shows you how, it is just another parameter in the URL, selectproperties='aProperty,anotherProperty' – Robert Lindgren Nov 16 '13 at 18:02
  • Did it work out for you? – Robert Lindgren Nov 17 '13 at 8:25
  • Hi, I just tried it now, it retrieved the value, but the column is text, and contains a text value, but in the xml it comes as <d:element m:type="SP.KeyValue"><d:Key>ServiceAccount</d:Key><d:Value m:null="true"/><d:ValueType>Null</d:ValueType></d:element> .. it comes as true, what's wrong with it? – SharePoint Freak Nov 17 '13 at 17:52
  • To me that indicates just that, no value. Have you performed a full crawl and made sure the name of the managed property is correct? – Robert Lindgren Nov 17 '13 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.