0

I migrated my InfoPath 2010 list to a new site collection. Now when a user selects "New Item" it opens my Read Only view. How do I reset this?

enter image description here

1

To change the view follow the below steps,

  1. Open your list in which you want to change the view of InfoPath.

  2. Select list settings.

  3. Select Advanced Settings

  4. Make the last option "Launch forms in a dialog?" to "NO" and click "OK".

  5. Now Navigate to the List and click on "New item", form will be opened in a new tab/window.

  6. The URL of the opened new tab/window would be similar to the below URL

http://Server-name/sitesname/Lists/sample/Item/newifs.aspx...

?PageView=Shared&ToolPaneView=2

append the above hilighted text in the above URL. so that the URL will become as below,

http://Server-name/sitesname/Lists/sample/Item/newifs.aspx?PageView=Shared&ToolPaneView=2

and press enter.

  1. Now the page will be opened in EDIT MODE, edit the "InfoPath Form Web Part".

  2. In the properties of the webpart, you can find the "Select the form view to display by default" section with a drop down, select the desired view and click "Apply" and then click "OK".

  3. Now navigate back to list -> List Settings -> Advanced settings -> "Launch forms in a dialog?" to "Yes" and click "OK".

Try the above method, the same can be done through SharePoint designer aswell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.