0

We have an issue in SharePoint (Enterprise) 2010 with our Top Link NavBar inheritance and permissions across sub-sites.

Current Configuration

We have a root site collection: RSC1. Under the root site collection we have 2 (sub) sites: Site1 and Site2.

Each sub site Site1 and Site2 does not inherit security permissions from the root site collection RSC1. However, it does inherit the Top Link Bar.

We have a number of users who can access the sites.

  • Site1User - Member of the 'Site1 Members' which have the Contribute Permission.
  • Site1Admin - Member of the 'Site1 Owners' which has the Full Control Permission.

Site1Admin and Site1User do not have any permission to access Site2. If they navigate directly to this site they get the Access Denied error.

Access Issues

  • When Site1User accesses the RSC1 site, they see Home and Site1 links in the Top Link Bar Navigation.

  • When Site1User visits the Site1 site, they see Home and Site1 links in the Top Link Bar. This is how I expect it to work.

  • When Site1Admin accesses the RSC1 site, they see Home and Site1 links in the Top Link Bar Navigation.

  • When Site1Admin visits the Site1 site, they see Home, Site1 and Site2 links in the Top Link Bar.
  • When Site1Admin clicks the Site2 link they get the Access Denied screen. Clicking "Back To Site" link takes them back to Site2 Home Page, which they don't have access to, and therefore they are in an endless loop (which the admin users do not like).

I would expect Site1Admin not to see the Site2 site in the Top Link Bar Navigation from Site1 as they do not have permission to access this site.

However, as this is still essentially my first SharePoint 2010 project I am a bit baffled. Any thoughts on how I can prevent Site1Admin from seeing the Site2 link from the Site1?

1

Could you please advice how would I do that in Sharepoint Foundation 2010?

I had to delete on of the links created along with a Site it was linking to(it was only visible to poeple intended to see it). When I recreated it manually, I got into a problem that people that not suppose to see that link(bacause they don't have permission to access that site) can see it.

Only thing I noticed is that when going to Site Settings--> Top link bar--> click on link one I recreated can be edited, other links that were created along with a sites they are linking to can not be edited and a Type the Web address field is greyed out for them.

Please help to resolve this issue.

0

I received an answer from Dennis Guo on MSDN Forums here MSDN SharePoint

He said "From your description, you want to make the Top Link visible true/false based on user permission.

First make sure to enable the Publishing feature of your site.

Once that is done we can use Security Trimming and Audience Targeting for your top link bar."

More information:

How to setup

So to enable the Publishing feature, you need to (at top level site):

  1. Enable SharePoint Server Publishing Infrastructure under Site Actions->Site Settings->Site Collection Features before
  2. Enable Publishing under Site Actions->Site Settings->Manage site features.

    This will enable the Navigation link under Site Actions->Site Settings.

  3. In the Navigation screen in the section Navigation Editing and Sorting you will see a layout from the site including sub sites.

Typically Global Navigation shows the subsite links. You can click on each one of these then click on the Edit... button.

The Audience field allows you to select a list of groups from either Global Audiences, Distribution/Security Groups, or SharePoint Groups.

For me I selected the groups from SharePoint Groups.

Now when users look at the Top Link Bar they only see the sites they have permission to access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.