0

(I have originally posted this question to Azure forum few days ago and repeating it here as i get no response there and i just discovered this site. Thanks in advance...)

I have installed Workflow Manager 1.0 in a dedicated domain machine (I did it in too many different ways getting the same result for my desperation. I tried both MSDN way and harbar.net way. Actually tried some variations there as well esp. involving certificate options suspecting security/authorization issues)

Any hints, help welcome as it already took too long to have SP2013 workflows running :-(

Problem: Despite it is possible to

  • Get the XML from the REST API using IE/Chrome Create child scopes
  • (using powershell scripts) See that # child scopes > 0 after having created child scopes in REST API XML for root API site from a browser or using workflow manager powershell scripts for enumerating childs
  • Get the XML from the REST API using IE/Chrome for child scopes and
    see that they are there with properly configured admin groups

we have following issues

  • Fetch info about any child other than root ("/")

  • Workflow explorer cannot open up child scopes for property view (it shows #child scopes > 1)

  • Sharepoint pairing fails returning 404.

  • Trying to fix SP pairing, i manually created a child scope (SharePoint) and tried to pair it with SP2013. It did not matter.

I have the following diagnostic (analytic/debug) events from the Workflow Manager Machine:

//Event logs form Workflow Manager 1.0

Re-routing request '..:12290/SharePoint/' to '..:12290/$Scope'

Scope '/SharePoint' security settings are retrieved from cache.

Scope '/SharePoint' security settings are retrieved from cache.

Windows Identity Present. Name = ..\sp_farm

The HTTP request was authenticated using the 'Negotiate' credential type and was granted the following permissions: All.

The HTTP request was authorized to perform the specified operation.

Gateway sending HTTP response: StatusCode: 200, ReasonPhrase: 'OK', Version: 1.1,

Content: System.Net.Http.ObjectContent`1[[Microsoft.Workflow.Management.ScopeInfo, Microsoft.Workflow.Management, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]], Headers: { Server: Microsoft-WF/1.0.1 Content-Type: application/xml; charset=utf-8 }

// Things go crazy starting wit this line: Gateway received request details: Method: GET, RequestUri: '...:12290/$System/$Metadata/json/1', Version: 1.1, Content: System.Net.Http.StreamContent, Headers: { Host: ...:12290 }

//Request is re-routed:

Re-routing request "...:12290/$System/$Metadata/json/1" to '...:12290/$Scope'

//First message that does not sound good

Scope '/$System/$Metadata/json/1' is not in scope map.

//Comes the exact same messag again

Scope '/$System/$Metadata/json/1' is not in scope map.

//And finally REST caller app gets this:

Gateway sending HTTP response: StatusCode: 404, ReasonPhrase: 'Not Found', Version: 1.1, Content: System.Net.Http.ObjectContent`1[[Microsoft.Workflow.Gateway.WorkflowManagementError, Microsoft.Workflow.Gateway, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]], Headers: { E2EActivity: ygPqDXf5HEysw9rCtgh3vQ== Scope: /$System/$Metadata/json/1 NodeId: ALTEMIS-SVR02 Server: Microsoft-WF/1.0.1 Content-Type: application/xml; charset=utf-8 }

  • I have the same problem. Is this problem still occurring or have you found a resolution? Thank you. – FelixC Nov 25 '13 at 18:45
  • It was about Windows 2012 "R2". With non-R2 server 2012, the problem does not occur. – mami Jan 10 '14 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.