2

Users of a SharePoint Document Library are getting this error:

The URL for this file is too long for the application. A temporary copy of this file will be opened on your computer. You must save this copy as a new file.

After doing some research, it appears Internet Explorer has a limit of about ~250 characters for a URL. Some URLs provided by SharePoint far exceed this limit. One example being 790 characters long.

Is there a way to disable this limit? I have looked, but there doesnt appear to be a solution, other than shortening the folder/path names.

migrated from superuser.com Nov 13 '13 at 17:21

This question came from our site for computer enthusiasts and power users.

5

Sorry, looks like the answer is no.

No, this is a hard limit in SharePoint. Studying the schema of the content database reveals the limit originates from the primary key columns DirName and LeafName in the AllDocs table.

The only way is to work around it by creating shorter names. They do offer a link to a tool to help (see source), but not sure if editing the filenames/paths is an option or not?

Source

  • But why should it have to do sth with Content DB Limits when for Chrome it is working? – tommypage777 May 23 '17 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.