I have a document library with a custom (document) content type set as default (the only content type), and I've edited the template to use columns to populate the document.

When I create a new document in the library, the document based off the template opens in Word, and the 3 content type fields that correspond to my columns are available for editing in Word. When I save the document, that information is visible in the columns of the library.

BUT when I created a workflow on a list (with those same site columns) with the only workflow action being to create a new list item in this document library, the workflow completes successfully, the columns on the document library are populated, but the document itself is completely blank!

Does anyone have any ideas on how to solve this?

  • did you ever get an answer on this?
    – user2571
    Mar 7, 2011 at 13:12

1 Answer 1


This isn't really a proper answer, but rather a workaround for the problem. I came accross exactly the same issue when creating the workflow through the Workflow interface in SharePoint itself, and couldn't find a solution.

However, a colleague of mine tried the same workflow using the SharePoint Designer application, and it worked fine, and creates proper Word documents now. This is on the same list and document library, so there are no configuraiton differences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.