After a rather hasty (unavoidable) migration/reconfiguration of a SP 2010 Foundation box, I am left with an error in CA regarding a number of missing Features, SetupFiles, and WebParts. I redeployed and then retracted and uninstalled the two solutions that were the cause of the majority of the messages (they weren't being used, which is why they weren't migrated initially) and while the errors went away while the solutions were deployed (except for one regarding a missing template file that had been renamed), they came back after the removal and I'm not sure how to eliminate the references to the "Missing server side dependencies."

I ran WssAnalyzeFeatures to confirm the damage, and, sure enough, even after the removal of the solutions, the errors remain.

Any suggestions for tools and/or steps to remove these errors?


The two main tools for dealing with upgrade problems on your SharePoint 2010 farm are the Test-SPContentDatabase Powershell command and the stsadm command enumallwebs.

The Test-SPContentDatabase tool will check the content db against a specific site collection. It can be safely run either before or after the database is attached, as often as required. I would avoid running it against a live production database - take a copy.

Test-SPContentDatabase –Name dbame -WebApplication url

Use the enumallwebs stsadm command to work out which webparts, features, etc. are associated with which sites. You may discover orphaned sites that can be deleted and which may be the source of your problems.

stsadm -o enumallwebs -databasename dbname -includefeatures -includesetupfiles -includewebparts -includeeventreceivers -includecustomlistview

You would usually also want to review your upgrade error log, although it sounds as though you are beyond that point.

  • The missing parts do not correspond to any orphaned sites, so that fix is unfortunately not available and thus I have to be more sophisticated. Is there a way to backtrack up the chain to find what is actually referencing the missing features and files? For example, given the output from stasdm -o enumallwebs, I get " <SetupFile Path="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\Features\roxority_UserListWebPart\roxority_UserListWebPart\roxority_UserListWebPart.webpart" Count="1" Status="Missing" />", but I don't know what is referencing the file. Thoughts? – mjbraun Jan 5 '11 at 17:51

Well, I was able to solve my particular error, though it was only by means of a cumbersome process.

I loaded this stored procedure onto each affected database which allowed me to search the entire database for a given string. I searched though the database based on the error strings to finally identify the affected pages. One problem that was causing the error is that while I had emptied the main site Recycle Bin, I had never cleared out the Recycle Bin on the Admin site.

It was an ugly, ugly hack, but it worked. I wish I could share a step-by-step but it's a totally unique scenario for each system. Also, I imagine for a site with any degree of content, the searches through the databases might take aeons.


Detaching and reattaching the content db fixes the most obvious discrepancies between the config and the content db.

  • Did that, but nothing changed. Alas, but thank you for the suggestion! – mjbraun Jan 5 '11 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.