1

I have a development Sharepoint 2010 enterprise edition. My account has full control and SPShellAdmin credentials on the SQL database farms. Last spring I developed some custom web parts for my company. After deploying the code to production around early summer I have not logged in or touched it or the dev SQL server until yesterday to start developing some new additions. When I attempted to run the code I got an error:

Error occurred in deployment step "Recycle IIS Application Pool". The local SharePoint server is unavailable. Check that the server is connected to the SharePoint Farm

So after checking the application pool i decided to check SharePoint Central Administration where i get this message:

Cannot browse to the SharePoint Central Administration Web Application because a SharePoint Central Administration Web Application has not been created yet. To create one, use the SharePoint Products Configuration Wizard. Do you want to launch the configuration wizard now?

I click yes, enter the dev sql server name, and select my sharepoint config. Then it asks for a passphrase. The company i work for has a high turnaround with consultants so the person who created the dev server no longer works here and did not leave any documentation when he set up the server. I sent an email to his company but until i get a reply i have to assume he does not have that information or does not work there anymore.

So i found a couple options: 1st use Sharepoint management shell to reset the passphrase or 2nd create a new SharePoint farm, use the farm credentials to then reset the passphrase on the correct farm as described Here

First option: I launch management shell as administrator. I get the error

"The local farm is not accessible. Cmdlets with FeatureDependancyId are not registered."

I ran the command Add-PSSnapin Microsoft.SharePoint.PowerShell which said it is already added. I then edited the properties of management shell to be version 2, and eventually uninstalled the powershell version 3 update altogether and I still have this issue. These three are the most common causes for this error and I can't find anything else with this error. Because i am not able to run any SharePoint commands i am not able to reset the passphrase through the SharePoint Management Shell.

Second option: I created a new farm using the Central Admin wizard and gave it a passphrase "Passphrase1" since it is temporary. In the blog I am following it suggests central admin will open, but that did not happen. So i tried launching it and got the same error. So I attempt to set it up with the new temp farm, get to the passphrase portion and it says the passphrase is incorrect.

I seem to have hit two dead ends here. Does anyone have any advice on where to go from here?

Thanks

2

Back up your Content DBs (if an all in one box), flatten the system and rebuild from scratch.

SharePoint environments can be quite disposable in a way - it is often far faster to rebuild a web front end than to troubleshoot an issue. Farms can also be rebuilt from backups sometimes much faster than troubleshooting issues like these.

  • 1
    Thanks, that is a fair point. If i go that route I'll mark this as the answer. – heilch Nov 8 '13 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.