0

I would like to know if it is possible to give permissions to users in a form library or document library where the users will be able to click on + add document link and submit and save their changes but not able to view the document that they just saved or anyone elses. I used the work flow action to impersonate account-->replace list items-->Lookup for person or group-->data source: current item but I am not sure what to choose for the field from source. Is this possible through a workflow?

Or Can a workflow copy the form to a different library as soon as it is saved and deleted from the library where it was initially saved?

Thanks a ton for your help in advance

0

Assuming the impersonation action you are choosing is "Replace List Item Permissions". The 2 values you need to provide are: 1. "these permissions", which are the new permissions as this action will delete all of the existing permissions. If you need a new permission level with only limited permissions, you should created that before you add this action so it is available in the select list. 2. "this list", which should be "Current Item", to alter the permissions for only one item in the list.

This works nicely.

  • Instead I created a workflow to copy the new form created to a new library and delete the source form. The workflow works perfect for me since I am the domain admin. However on the second library where the forms are being saved I gave only few team members full control permissions and they are able to view their forms as expected. But I still want other team members to not view the library of forms in the second library so I didnot give them permissions to this. So when they submit form in first library the workflow is failing for them. Do you think restrict read access will resolve the issue? – user20658 Nov 8 '13 at 16:52
  • The error why the workflow failed is:The workflow could not copy the item. Make sure the source and destination lists have the same columns and column settings. – user20658 Nov 8 '13 at 17:20
  • I think I figured it out. In the workflow action I had my workflow setup in step1 instead of impersonation step. As soon as I changed this its working fine. I am glad its fixed but I dont know the difference between step 1 and impersonation step. – user20658 Nov 8 '13 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.