0

I am getting following error while restoring the backup (.bak) file on my SharePoint server (SharePoint 2010). The backup file resides on the same machine.

Restore-SPSite : This operation can be performed only on a computer that is joi ned to a server farm by users who have permissions in SQL Server to read from t he configuration database. To connect this server to the server farm, use the S harePoint Products Configuration Wizard, located on the Start menu in Microsoft SharePoint 2010 Products.

At line:1 char:15 + Restore-SPSite <<<< -Identity http://: -Path "c:\abc\file.bak" -force + CategoryInfo : InvalidData: (Microsoft.Share...dletRestoreSite: SPCmdletRestoreSite) [Restore-SPSite], SPException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRestoreS ite

  • Are you running the backup with an account that has access to the config DB? – Kit Menke Dec 29 '10 at 14:58
  • Yes, I am. In fact I am admin on that server. – Great SharePoint Dec 30 '10 at 5:59
  • By "that server" do you mean the SQL server or the SharePoint server? The account will need rights to both. – Kit Menke Dec 30 '10 at 14:45
  • Maybe look at the SQL logs to see which account is trying to access SQL (there should be something like an access denied error)? – Neil Richards Jan 2 '11 at 23:04
1

This appears to be an error with the server. I know you state that it is joined to the farm, but it appears to be unable to connect to the configdb. Are you using SQL aliasing at all? If so, it may be that the sql alias is not configured correctly to point to the correct SQL server. Another option is that the server has somehow lost the ability to communicate with the SQL server. I have often gotten a similar error in either situation.

1

When you launch powershell be sure to "Launch as Administrator"

0

Are you a shell admin?

Try this:

$db = get-SPContentDatabase ContentDBNamehere
Add-SPShellAdmin –Username Domain\User -database $db
0

i have the same problem when i was trying to restore backup to a different moss server and i got the same error you have here

the problem was that backup file is seted to readonly , i solved the problem by just unchecked read only flag at file properties window from right click on the file => properties then i executed the command again successfully

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy