10

How do I customize the sign out and access denied pages in SharePoint 2013?

After sign out code I ran the power shell script but this doesn't seem to be working.

Have I missed anything?

Powershell script:

Set-SPCustomLayoutsPage -Identity "Signout" -RelativePath "/_Layouts/SignOutCustom/SignOut.aspx" -WebApplication url
9

There is an identified issue with SharePoint 2013 ignoring the values set through the Set-SPCustomLayoutsPage cmdlet.

See: Custom Access Denied Page in SharePoint 2013.

Although the same UpdateMappedPage method and Set-SPCustomLayoutsPage cmdlet exists in 2013, there is an identified bug in the product related to the property. The custom location can be set using either of these methods, but SharePoint will not recognize them and will continue to use the out of the box accessdenied.aspx page.

The comments on that page suggest that it is expected to be patched Feb. 2014.

Additionally, in SharePoint 2013, the path to files in the layouts folder has changed. If the files are in the 15 hive, your path should be /_layouts/15/SignOutCustom/SignOut.aspx.

The article Virtual directories in SharePoint 2013 solutions explains this as:

For files in the virtual folders _layouts or _controltemplates, SharePoint needs to use the version of the files in %ProgramFiles%\Common Files\Microsoft Shared\web server extensions\15\ (sometimes called the 15 hive) or in the corresponding 14 hive, depending on the mode of the site collection. SharePoint adds “/15” into the virtual directory path just after the virtual directory name to signal that the SharePoint 2013 files should be used. The absence of that extra string indicates that SharePoint 2010 files should be used.

  • Not working . Set-SPCustomLayoutsPage -identity "Signout" -RelativePath "/_layouts/15/CUSTOMSIGNOUT/signout.aspx" -WebApplication "window-asadsa:6205" Set-SPCustomLayoutsPage -identity "Signout" -reset -WebApplication "win-asadsa:6205" – Nik J Nov 7 '13 at 2:43
  • Sorry you're having this problem. This appears to be a known bug in SP 2013. – RJ Cuthbertson Nov 7 '13 at 3:19
  • Also, looking at your profile I've noticed that you have a lot of questions that you've asked without accepting answers. Would you please review some of your older posts and accept the answers that appropriately addressed your questions? – RJ Cuthbertson Nov 7 '13 at 3:28
  • That's the link in my answer. – RJ Cuthbertson Nov 7 '13 at 19:18
2

There is a Bug in SharePoint in setting up Custom Access Denied Page. To achieve this, please find the workaround in below URL

Configure Custom Access Denied Page - BUG in SharePoint 2013

  • 1
    Please do not post link only answers to your own blog! Include the details here and use the blog URL as a source and nothing more! – Robert Lindgren May 20 '14 at 16:10
0

You should update sharepoint server to october or november build. Don't forget to run iisreset after spcustom layoutpage execution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.