6

I have successfully added a provider hosted app to the app catalog.

However, when I go to the main site, then go to the "gear" icon, and select "Add an app", it gets stuck at "Loading" forever.

If I view javascript errors, in IE 10 see:

SCRIPT5007: Unable to get property 'className' of undefined or null reference 
ScriptResource.axd, line 5 character 59249

And in Firefox I see:

Error: TypeError: b is null
Source File: https://blah.test.net/ScriptResource.axd?d=SsARyFD3_rQCMDLd6IgfYaxJnLFnvxkC1Xtj47fGS-nQa4JCl2bx2MyfQ9rvUL53P-WbzGFUoUC-lVUcbrX5lHQ6RNC1BnccNHsuuoi76QciKDMPANw6dKkz8pgiX5fuW6ysOtL6n0GoF-4xlZkviLwqYgxj75pJxS4GjF0C38uNL2diSVl0z48saetHiQmE0&t=6119e399

Line: 5

I retried the request and then grabbed the most recent logs via SharePoint management console with the below command:

get-splogevent -starttime (get-date).addminutes(-1) | fl message > error.txt

Examining the error logs, I can't find any smoking gun.

How can I fix this so that I can add an appmodel app to a publishing site?

7

Turns out there is a bug in the SharePoint master designer in SharePoint 2013 RTM.

See: http://blog.drisgill.com/2012/12/design-manager-bug-sharepoint-2013-rtm.html

Basically, you have to ensure that your master page contains specific items.

  • Thanks Nathan. Just removing Visible=False from DeltaPlaceHolderLeftNavBar fixed my issue. MS should have a fix for this as its been existing since 2012 – Michael Colbs Jul 15 '14 at 14:58
3

enter image description here

Specifically, if you are using Sharepoint Designer 2013, your code should look like this (notice Visible="false" has been removed)

2

This issue might occur because of

enter image description here

  • You may have a system custom master page that some placeholders were deleted or its visibility set to false.
  • The app installation service timer job is disabled.

To trace the issue, you need to set back the current master page to the default master page (not customized) to can load your Apps properly.and in this case you needs to add the missing placeholders to your custome master page as I have mentioned at Add an App Stuck on Loading in SharePoint 2013

  • 1
    Unable to access the above URL @Qassas – Suriya Mar 17 '17 at 7:38
  • @Suriya Thank you so much, for your feedback, it's a strange behavior! I have resolved the link! and it can be accessible now :) – Mohamed El-Qassas MVP Mar 17 '17 at 11:26
1

add the below lines in the master page, it works for me, also place it under this section

<div class="ms-hide">:

 <!--SPM:<SharePoint:AjaxDelta id="DeltaPlaceHolderLeftNavBar" BlockElement="true" runat="server">-->
 <!--SPM:<asp:ContentPlaceHolder id="PlaceHolderLeftNavBar" runat="server">-->
 <!--SPM:</asp:ContentPlaceHolder>-->
<!--SPM:</SharePoint:AjaxDelta>-->
<!--SPM:<SharePoint:AjaxDelta id="DeltaPlaceHolderPageTitleInTitleArea" runat="server">-->
<!--SPM:<asp:ContentPlaceHolder id="PlaceHolderPageTitleInTitleArea" runat="server">-->
<!--SPM:</asp:ContentPlaceHolder>-->
<!--SPM:</SharePoint:AjaxDelta>-->

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.