I have the SharePoint 2013 RTM Farm from Cloudshare.

This SharePoint topology includes a server with SharePoint 2013 Enterprise RTM, Visual Studio 2012 and Office 2013 RTM, an additional server with Active Directory and a separate server for SQL Server 2012. Use this showcase for multi-server farm development and testing. Add additional server(s) by using the "SharePoint 2013 RTM Additional Server Bits Only" Template.

I was configuring some services (Search, User Profile Sync, etc) and cleaning some errors form the Health Analyzer. I had to create some accounts, modify some service accounts, add some accounts to the local adminsitrator group, I don't even know what I did to have everything working and Sharepoint not complaining about stuff.

Thing is now I can't deploy Apps. As you see, I could before, but now I'm getting an error while trying to UNINSTALL the app from VS. And the SharePoint site shows me as "System Account" instead of "AD2012\Administrator" (which is the user I'm logged in). Although in Central Administration I'm logged as Administrator not System Account. So it's something with the site.

Can anyone point me exactly where I screwed things up? I'm not a SharePoint expert so

2 Answers 2


AD2012\Administrator was set as the account for the Web Application Pool 80 corresponding to the Sharepoint site. Changing it to another account in CA > Security > Configure service accounts and restarting IIS solved the problem.


By Default, Administrator is System Account itself. For security reason, you neither can install nor uninstall the app as a System Account.

So, create a new user and assign that user a dbowner permission through SQL server management studio to app management database, SharePoint subscription setting database and the current content database where you are deploying the app. Assign the user in Administrator group. Then login to server with user credential and open the VS as a administrator there and open the app solution. Deploy it, it should work like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.