1

In visual studio 2010, I have a gridview, with another inside, this has been working fine for 3 weeks, but today, it randomly begins to move to the right in designer, not when deployed, its jumping a few pixels every few seconds, but this goes on infinitely jumping continuously to the right, before I set the gridview to a limit of 1000px, each column would grow infinitely but now this gridview is limited it moves sideways infinitely until the cpu usage is so high it crashes.

I'm stuck, I have no idea what is causing it, or if its a random visual studio error. Any pushes in the right direction are appreciated.

The page is a Visual Web part as part of a customized SharePoint project and the gridview is populated with elements pulled from a SharePoint list. The Gridview ASP.net code is as follow:

<div style="width: 100%; margin-left: 2.5%;">
                            <asp:GridView ID="GV_Projects" runat="server" AutoGenerateColumns="False" CssClass="mGrid"
                                PagerStyle-CssClass="pgr" AlternatingRowStyle-CssClass="alt" DataKeyNames="ProjectID"
                                OnRowDataBound="OnRowDataBound" EnableModelValidation="True" Style="width: 1000px;
                                float: left;">
                                <AlternatingRowStyle CssClass="alt"></AlternatingRowStyle>
                                <Columns>
                                    <asp:TemplateField ItemStyle-Width="5%">
                                        <ItemTemplate>
                                            <img alt="" style="cursor: pointer" src="~/_layouts/images/BG_DevelopmentSystem/plus.png" />
                                            <asp:Panel ID="PNL_ModuleDetails" runat="server" Style="display: none">
                                                <asp:GridView ID="GV_ModuleDetails" runat="server" AutoGenerateColumns="false" CssClass="ChildGrid"
                                                    OnRowDataBound="Module_OnRowDataBound" Style="width: 100%">
                                                    <Columns>
                                                        <asp:BoundField DataField="ModuleID" HeaderText="ModuleID" ItemStyle-Width="0" />
                                                        <asp:BoundField DataField="ProjectID" HeaderText="ProjectID" ItemStyle-Width="0" />
                                                        <asp:BoundField DataField="Title" HeaderText="Title" ItemStyle-Width="15%" ItemStyle-Font-Bold="true" />
                                                        <asp:BoundField DataField="ModuleType" HeaderText="Module Type" ItemStyle-Width="10%" />
                                                        <asp:BoundField DataField="Start Date" HeaderText="Start Date" ItemStyle-Width="10%" />
                                                        <asp:BoundField DataField="End Date" HeaderText="Est End Date" ItemStyle-Width="10%" />
                                                        <asp:TemplateField HeaderText="Progress" ItemStyle-Width="40%">
                                                            <ItemStyle HorizontalAlign="Center" />
                                                            <ItemTemplate>
                                                                <table style="width: 100%; border-color: white; border-style: solid; border-width: 1px"
                                                                    id="TBL_ProgressMin" runat="server" visible="True">
                                                                    <tr>
                                                                        <td style="height: 5px; width: 50%; background-color: Green; text-align: left; border: none;"
                                                                            id="TD_ModuleCompleteMin" runat="server">
                                                                            <asp:Label ID="LBL_ModuleComplete" runat="server" Text="" Font-Bold="True" Font-Size="XX-Small"
                                                                                ForeColor="White" Visible="false"></asp:Label>
                                                                        </td>
                                                                        <td style="height: 5px; width: 50%; background-color: Red; text-align: right; border: none;"
                                                                            id="TD_ModuleIncompleteMin" runat="server">
                                                                            <asp:Label ID="LBL_ModuleIncomplete" runat="server" Text="" Font-Bold="True" Font-Size="XX-Small"
                                                                                ForeColor="White" Visible="false"></asp:Label>
                                                                        </td>
                                                                    </tr>
                                                                </table>
                                                            </ItemTemplate>
                                                        </asp:TemplateField>
                                                        <asp:TemplateField HeaderText="Log Module Feedback/Bug" ItemStyle-Width="10%">
                                                            <ItemStyle HorizontalAlign="Center" />
                                                            <ItemTemplate>
                                                                <asp:ImageButton ID="IMG_Feedback" runat="server" ImageUrl="~/_layouts/images/BG_DevelopmentSystem/feedback.png"
                                                                    CssClass="FeedbackButton" OnClick="feedback_Click" ToolTip="Click here to log bugs/feedback" />
                                                            </ItemTemplate>
                                                        </asp:TemplateField>
                                                    </Columns>
                                                </asp:GridView>
                                            </asp:Panel>
                                        </ItemTemplate>
                                        <ItemStyle Width="5%" />
                                    </asp:TemplateField>
                                    <asp:BoundField DataField="ProjectID" HeaderText="ProjectID" ItemStyle-Width="0%">
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Title" HeaderText="Title" ItemStyle-Width="10%" ItemStyle-Font-Bold="true">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:TemplateField HeaderText="Project Progress" ItemStyle-Width="10%">
                                        <ItemStyle HorizontalAlign="Center" />
                                        <ItemTemplate>
                                            <%-- border-color: Black; border-style: solid; border-width: 1px--%>
                                            <table style="width: 100%;" id="TBL_ProgressMin" runat="server" visible="True">
                                                <tr>
                                                    <td style="height: 5px; width: 50%; background-color: Green; text-align: left; border: none;"
                                                        id="TD_ModuleCompleteMin" runat="server">
                                                        <asp:Label ID="LBL_ModuleComplete" runat="server" Text="" Font-Bold="True" Font-Size="XX-Small"
                                                            Visible="false"></asp:Label>
                                                    </td>
                                                    <td style="height: 5px; width: 50%; background-color: Red; text-align: right; border: none;"
                                                        id="TD_ModuleIncompleteMin" runat="server">
                                                        <asp:Label ID="LBL_ModuleIncomplete" runat="server" Text="" Font-Bold="True" Font-Size="XX-Small"
                                                            Visible="false"></asp:Label>
                                                    </td>
                                                </tr>
                                            </table>
                                        </ItemTemplate>
                                    </asp:TemplateField>
                                    <asp:BoundField DataField="Developer" HeaderText="Developer" ItemStyle-Width="10%">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Division" HeaderText="Division" ItemStyle-Width="10%">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Stakeholder" HeaderText="Stakeholder" ItemStyle-Width="10%">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Description" HeaderText="Description" ItemStyle-Width="20%">
                                        <ItemStyle Width="20%" />
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Due Date" HeaderText="Due Date" ItemStyle-Width="10%">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:BoundField DataField="Status" HeaderText="Status" ItemStyle-Width="10%">
                                        <ItemStyle Width="10%" />
                                    </asp:BoundField>
                                    <asp:TemplateField HeaderText="Log Project Feedback/Bug" ItemStyle-Width="10%">
                                        <ItemStyle HorizontalAlign="Center" />
                                        <ItemTemplate>
                                            <asp:ImageButton ID="IMG_Feedback" runat="server" ImageUrl="~/_layouts/images/BG_DevelopmentSystem/FeedbackBug.png"
                                                OnClick="feedbackProj_Click" ToolTip="Click here to log bugs/feedback" />
                                        </ItemTemplate>
                                    </asp:TemplateField>
                                    <asp:TemplateField HeaderText="Open Project" ItemStyle-Width="10%">
                                        <ItemStyle HorizontalAlign="Center" />
                                        <ItemTemplate>
                                            <asp:ImageButton ID="IMG_OpenProj" runat="server" ImageUrl="~/_layouts/images/BG_DevelopmentSystem/OpenProj.png"
                                                OnClick="openProj_Click" ToolTip="Click here to open the project" />
                                        </ItemTemplate>
                                    </asp:TemplateField>
                                </Columns>
                                <PagerStyle CssClass="pgr"></PagerStyle>
                            </asp:GridView>
                        </div>
  • Just an advice. This question is likely to get closed as off-topic.. While I don't support it - I don't feel I know enough of this problem to say it is NOT somehow SharePoint related (the VS designer is know for having problems with SP pages) - I would also suggest to have a go on stackexchange if this post get closed. Maybe someone there may have some more clue about the problem. – SPArchaeologist Oct 31 '13 at 13:00
  • Please run the javascript profiler in Internet Explorer, this will record what is being called. From here you can see what is being called repeatedly and you can put a breakpoint on it (Put the JS in debug mode in the web.config) you can then see what is causing the issue and patch. I have voted for a reopen as this is clearly a SharePoint issue. – Hugh Wood Nov 5 '13 at 22:09
  • @HughWood I believe he is experiencing the problem inside visual studio, not IE. "it randomly begins to move to the right in designer, not when deployed". This seems more like a bug in the VS designer - which may still be specific to SharePoint development. It would be interesting to try to verify if the problem is reproducible... if that would be the case maybe the issue could be posted to Microsoft Connect. – SPArchaeologist Nov 7 '13 at 12:57
  • Sorry I should of been more clear, the internal browser uses an IE frame. So surely you should be able to run a profiler on it? – Hugh Wood Nov 8 '13 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.