0

I'm dropping a List View that was made from an imported Excel spread sheet into one of my sharepoint pages. Rather confusingly, once it's in there, any changes I make to the "All Items" default view do not apply to the list view web part sitting on my page, as they only apply to the list its self (i.e when I click on the link to the list view). When I open up the List Tools on the sharepoint page, the Current View is set to a non-existent "Default" view. When I pull down the list to select All Items, it redirects me to the list its self (where the proper settings are applied), but does not apply it to the web part I was just editing. See picture for the current view.

Can anyone explain to me why my view, and consequently my conditional formatting, is not being applied to the web part list view?

The issue

1

When you set a web part to use a pre-defined view it essentially makes a copy of it so if you then change the view it will not be reflected in the web part. If you want these changes to come through to the web part then you will have to revisit it and reselect the view you want to use.

You can create a number of views for a list and choose which of them is the default - so there is not necessarily a view called default - it is just the one that is used when a user first lands on the list.

  • Alright... so I think that's what I have up there. Just one view named "All Items" which should be default for everything, and which I keep trying to select, although I end up getting redirected to the list its self, instead of the view being applied on-page where the list is sitting. – TGP1994 Oct 31 '13 at 15:17
  • I am a little confused where you are setting this. When you add a web part to a page then you need to click the little icon in the top right hand corner of the web part and select Edit web part. This will then bring up a small box to the right of your screen where you can change the properties, including setting which view to use. The image you have loaded above does not look right to me? – Dave Paylor Oct 31 '13 at 20:28
  • Ah yes, I didn't see that smaller box until today... it only looked like the page was refreshing, I just had to scroll to the right and there it was. The box was pre-set to something like <Current view>. After changing it to All Items and hitting apply/ok... nothing happens. Same thing. The image I have in the picture is from the List ribbon when you go to edit the web part. – TGP1994 Nov 1 '13 at 0:44
  • 1
    OK - when you edit the web part do you see a link to "Edit the current view"? Try clicking on that and you can set up the view for the web part any way you like. – Dave Paylor Nov 1 '13 at 8:21
  • Huh, yeah, I guess that did it this time. I was after conditional formatting so I had to do it in Sharepoint designer, but I guess this time applying the formatting directly to the list worked. Thanks! – TGP1994 Nov 4 '13 at 15:03
0

From the sounds of it, you should be editing the webpart view and not the library view. Try making sure that you have the correct view selected in the webpart settings. It is important to note that the webpart view and the list view can and often times will be different.

Hope I understood the question correctly.

  • I guess I'm not sure I entirely understand your answer... I thought that's what I was doing in my image above? I'm trying to select the "All Items" view which is the one I want, although it keeps redirecting me to the list its self instead of staying on the page that I want the list on. – TGP1994 Oct 31 '13 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.